Virtual Users and Domains : Mail Loops back to Myself

Discussion in 'Installation/Configuration' started by uni, Oct 5, 2009.

  1. uni

    uni New Member

    I followed the Ubuntu 9.04 tutorial two different times now and I always get the Postfix, " Loops back to myself" error so I was hoping for a little help. I've searched through all threads about this before posting, btw.

    I'm wondering if my MySQL transport table has the right values.

    Hostname =
    MX record points =

    I used '' in all my configs (except where it reflected domain name, and I put in '')

    Should my transport table value be:

    source + destination + (changed but not tested yet) + (this does not work)

    If there's anything else I can check, I'd appreciate some help as I'd really like to get this working.

    Output of 'postconf -n'

    Mailog error:

  2. falko

    falko Super Moderator ISPConfig Developer is already in the mydestination line, so I don't know why you still see that error. Did you restart Postfix?
  3. uni

    uni New Member

    RE: Virtual Domains, Mail loops back to myself

    Yes, I restarted Postfix many times . I've tried a lot of different things and then undone them when they didn't work. This is really strange. I can't get any further. Is there any Postfix diags I can run that would tell me what's going on?

  4. uni

    uni New Member

    RE: Virtual Domains, Mail loops back to myself SOLVED

    For some reason this line in /etc/postfix/ causes a mail loop for my system:

    #transport_maps = proxy:mysql:/etc/postfix/

    I basically reinstalled Postfix, got things working, then worked backwards to find the culprit.


    Also, as someone else mentioned, SpamAssassin is not enabled by default in the tutorial.
    pico etc/default/spamassassin
    ** Move it to ON, 1
    Last edited: Oct 9, 2009
  5. cpress

    cpress New Member

    After days of searching around trying to figure out what was going on (i had the same issue), I finally came across this.

    It actually has to do with the transport table itself. You do not need to populate this table. Keep it empty on a fresh install. It only applies if you are sending the message elsewhere to have it delivered.
  6. kramse

    kramse New Member

  7. kramse

    kramse New Member

    I enabled the line again, and emptied the transport table instead. Does this confllict in anyway with the line in
    relayhost = <here I have my isp smtp>

Share This Page