Virtual User Postfix Squirrelmail from Ubuntu 12.04 How-To recent update problems...

Discussion in 'HOWTO-Related Questions' started by kkimmell, Jan 28, 2015.

  1. kkimmell

    kkimmell New Member

    Hi,

    About 18 months ago I followed this How-To: https://www.howtoforge.com/virtual-...urier-mysql-and-squirrelmail-ubuntu-12.04-lts to setup a mail server on a website I'm hosting. It has worked flawlessly for that entire time... until somewhere around this past Monday. I ran my normal aptitude update/safe-upgrade routine for this Ubuntu 12.04 LTS server that morning. I can't recall what all was updated but no other changes were made to the system so this must have triggered it. I do know that none of the updates gave me the config screens you sometimes see which ask whether you want the new package config or to keep the current one.

    In any case, no email is getting out and the postfix queue is up to 1200 messages (it handles subscription and registration email for a medium sized forum community). In looking at mail.err and mail.log it seems like amavis is at the root of it... the pass-off is somehow getting confused. I apologize for not knowing more in terms of troubleshooting so I'm going to add some of the errors and hopefully someone can get me pointed in the correcty direction so as not to lose the 2000 and growing messages.

    tail of mail.err:
    Code:
    Jan 28 13:20:04 alerts amavis[3935]: (03935-03-21) (!!)TROUBLE in check_mail: forwarding FAILED: Error writing to socket: Broken pipe at (eval 98) line 200.
    Jan 28 13:24:48 alerts amavis[4142]: (04142-02-20) (!!)TROUBLE in check_mail: forwarding FAILED: Error writing to socket: Broken pipe at (eval 98) line 200.
    pertinent tail of mail.log (removed identifying info to protect users):
    Code:
    Jan 28 13:35:26 alerts postfix/cleanup[2824]: warning: proxy:mysql:/etc/postfix/mysql-virtual_forwardings.cf lookup error for "[EMAIL]USERNAME@gmail.com[/EMAIL]"
    Jan 28 13:35:26 alerts postfix/cleanup[2824]: warning: E960644DEFC: virtual_alias_maps map lookup problem for [EMAIL]USERNAME@gmail.com[/EMAIL] -- deferring delivery
    Jan 28 13:35:26 alerts amavis[1779]: (01779-06-8) Negative SMTP response to data-dot (<[EMAIL]USERNAME@gmail.com[/EMAIL]>): 451 4.3.0 Error: queue file write error
    Jan 28 13:35:26 alerts amavis[1779]: (01779-06-8) (!)FWD via SMTP: <[EMAIL]user@admindomainname.net[/EMAIL]> -> <[EMAIL]USERNAME@gmail.com[/EMAIL]>,BODY=7BIT 451 4.3.0 from MTA([127.0.0.1]:10025): 451 4.3.0 Error: queue file write error
    Jan 28 13:35:26 alerts amavis[1779]: (01779-06-8) Blocked MTA-BLOCKED, <[EMAIL]user@admindomainname.net[/EMAIL]> -> <[EMAIL]USERNAME@gmail.com[/EMAIL]>, Message-ID: <[EMAIL]ce4ccc85093882ce3638990ef6b2725b@oneofmydomainnames.net[/EMAIL]>, mail_id: iq9rnSCQbJgW, Hits: 0, size: 1634, 2349 ms
    Jan 28 13:35:27 alerts postfix/smtp[2830]: EBB9A44DAEE: to=<[EMAIL]USERNAME@gmail.com[/EMAIL]>, relay=127.0.0.1[127.0.0.1]:10024, conn_use=8, delay=1323, delays=1296/25/0/2.4, dsn=4.3.0, status=deferred (host 127.0.0.1[127.0.0.1] said: 451 4.3.0 id=01779-06-8 - Temporary MTA failure on relaying, from MTA([127.0.0.1]:10025): 451 4.3.0 Error: queue file write error (in reply to end of DATA command))
    Jan 28 13:35:27 alerts postfix/trivial-rewrite[2278]: warning: proxy:mysql:/etc/postfix/mysql-virtual_domains.cf: table lookup problem
    Jan 28 13:35:27 alerts postfix/trivial-rewrite[2278]: warning: virtual_mailbox_domains lookup failure
    Jan 28 13:35:27 alerts postfix/smtpd[2284]: 9AC5744DF08: client=localhost[127.0.0.1]
    Jan 28 13:35:27 alerts postfix/cleanup[2847]: warning: proxy:mysql:/etc/postfix/mysql-virtual_forwardings.cf lookup error for "[EMAIL]USERNAME@gmail.com[/EMAIL]"
    Jan 28 13:35:27 alerts postfix/cleanup[2847]: warning: 9AC5744DF08: virtual_alias_maps map lookup problem for [EMAIL]USERNAME@gmail.com[/EMAIL] -- deferring delivery
    Jan 28 13:35:27 alerts amavis[1778]: (01778-06-8) Negative SMTP response to data-dot (<[EMAIL]USERNAME@gmail.com[/EMAIL]>): 451 4.3.0 Error: queue file write error
    Jan 28 13:35:27 alerts amavis[1778]: (01778-06-8) (!)FWD via SMTP: <[EMAIL]user@admindomainname.net[/EMAIL]> -> <[EMAIL]USERNAME@gmail.com[/EMAIL]>,BODY=7BIT 451 4.3.0 from MTA([127.0.0.1]:10025): 451 4.3.0 Error: queue file write error
    Jan 28 13:35:27 alerts amavis[1778]: (01778-06-8) Blocked MTA-BLOCKED, <[EMAIL]user@admindomainname.net[/EMAIL]> -> <[EMAIL]USERNAME@gmail.com[/EMAIL]>, Message-ID: <[EMAIL]9fdce5068a9d1f8f6bba54fcbfff42d1@oneofmydomainnames.net[/EMAIL]>, mail_id: 1YhqN+MOrDvq, Hits: 0, size: 1613, 2355 ms
    Jan 28 13:35:27 alerts postfix/smtp[2827]: ED6484414F7: to=<[EMAIL]USERNAME@gmail.com[/EMAIL]>, relay=127.0.0.1[127.0.0.1]:10024, conn_use=8, delay=492498, delays=492470/25/0/2.4, dsn=4.3.0, status=deferred (host 127.0.0.1[127.0.0.1] said: 451 4.3.0 id=01778-06-8 - Temporary MTA failure on relaying, from MTA([127.0.0.1]:10025): 451 4.3.0 Error: queue file write error (in reply to end of DATA command))
    Jan 28 13:35:27 alerts postfix/qmgr[2152]: ED6484414F7: from=<[EMAIL]user@admindomainname.net[/EMAIL]>, status=expired, returned to sender
    Jan 28 13:35:27 alerts postfix/cleanup[2824]: warning: proxy:mysql:/etc/postfix/mysql-virtual_forwardings.cf lookup error for "[EMAIL]user@admindomainname.net[/EMAIL]"
    Jan 28 13:35:27 alerts postfix/cleanup[2824]: warning: ADFFF44DF1E: virtual_alias_maps map lookup problem for [EMAIL]user@admindomainname.net[/EMAIL] -- deferring delivery
    Jan 28 13:35:27 alerts postfix/qmgr[2152]: ED6484414F7: status=deferred (bounce failed)
    Any help/pointers greatly appreciated. How long before the queued messages start internal looping?

    -KK
     
    Last edited: Jan 28, 2015
  2. kkimmell

    kkimmell New Member

    So since nobody else has experienced this in the short term it seems like it wasn't the update or nobody else has updated. The problem with that line of thinking is that I am the only one with access to this server and I wasn't tinkering.
     
  3. kkimmell

    kkimmell New Member

    With the help of a user of our system it's been determined that the type of stuff shouldn't be in there. In looking at older logs it wasn't in there. The question now is what is introducing that stuff into the stream and how can I fix it?
     

Share This Page