Virtual Postfix Fedora 13 x86_64 - Mailboxes not created

Discussion in 'HOWTO-Related Questions' started by cejohnsonsr, Oct 6, 2010.

  1. cejohnsonsr

    cejohnsonsr New Member

    At the end of Pg5, 17 Send A Welcome Email For Creating Maildir, The user's mailbox isn't created. I noticed that doesn't specify a mailbox type so I used:
    postconf -e "home_mailbox = Maildir/"
    ...but still no user mailbox in /home/vmail.

    Since I have to use a relayhost, I also ran:
    postconf -e "relayhost = myrelayhost.domain.tld"
    I have found the messages I tried to send in /var/spool/clientmqueue. I'm not sure how to get the Maildirs created or how to get the messages out of the clientmqueue.

    NOTE: The directory /home/vmail was created.

    Advice appreciated.

    Last edited: Oct 6, 2010
  2. cejohnsonsr

    cejohnsonsr New Member

    Solved my own problem

    I found a typo in mysql_virtual_domains. Oops.

    The user directories are now created. I've managed to receive mail from a remote network. Can't get mail out, but that's due to a problem with my relayhost. Hopefully it will be fixed soon so I can continue testing & finish installation/configuration.

    The test messages sent before the Maildirs were created are still stuck in clientmqueue. What do I need to do to get them cleaned out?


  3. falko

    falko Super Moderator ISPConfig Developer

    To flush the mail queue, run
    postsuper -r ALL
    To delete all messages in the mail queue, run
    postsuper -d ALL

Share This Page