Virtual Hosts

Discussion in 'Installation/Configuration' started by jacksmerv, Dec 28, 2010.

  1. jacksmerv

    jacksmerv New Member

    Dear Guys,
    I have tried installing ubuntu 10.10, cent OS and Now i have installed Debian 5 with ISPconfig 3 step by step followed the instructions. Everything goes fine. In the ISPsonfig panel i have first created the Client, DNS and Website. I have checked the vi /etc/apache2/sites-available/example.in.vhost , vi /etc/apache2/sites-enabled/example.in.vhost . Everything looks fine. After that if i try to browse the website i have created it shows the default web page for the root /var/www ie., "IT Works ! ". What is the problem. I am not a expert in Linux, I am struggling with this for the past 15 days. Is any step i am missing ? Is anybody there in this universe , Please help to sort out this issue. Thanks in advance.
     
    Last edited: Dec 28, 2010
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please ensure that you access the website by domain name and not IP. You should also check if the domain that you want to use points with a dns A-Record to the IP address of the server and that you select "Auto subdomain: www" in the website settings.
     
  3. jacksmerv

    jacksmerv New Member

    Dear Till,
    As you said i have checked the things . My website is pointed to this server. If i try to restart apache2 it gives me the warning like this. /etc/init.d/apache2 restart
    Restarting web server: apache2[Tue Dec 28 09:30:46 2010] [warn] NameVirtualHost 180.151.50.116:443 has no VirtualHosts
    ... waiting .[Tue Dec 28 09:30:48 2010] [warn] NameVirtualHost 180.151.50.116:443 has no VirtualHosts

    is it related to anything ? You can browse indianwebdesigners.in and check please....
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Are there any jobs lsited in the jobqueue in the ispconfig monitor?
     
  5. jacksmerv

    jacksmerv New Member

    no nothing in the que

    ISPConfig Cron - Log

    SIOCDELRT: No such process
    SIOCADDRT: No such process
    SIOCADDRT: No such process
    SIOCADDRT: No such process
    SIOCADDRT: No such process
    SIOCADDRT: No such process
    SIOCADDRT: No such process
    [Tue Dec 28 07:11:02 2010] [warn] NameVirtualHost 180.151.50.116:443 has no VirtualHosts
    [Tue Dec 28 07:11:04 2010] [warn] NameVirtualHost 180.151.50.116:443 has no VirtualHosts
    [Tue Dec 28 07:11:06 2010] [warn] NameVirtualHost 180.151.50.116:443 has no VirtualHosts
    [Tue Dec 28 07:11:08 2010] [warn] NameVirtualHost 180.151.50.116:443 has no VirtualHosts
    [Tue Dec 28 09:29:01 2010] [warn] NameVirtualHost 180.151.50.116:443 has no VirtualHosts
    [Tue Dec 28 09:29:03 2010] [warn] NameVirtualHost 180.151.50.116:443 has no VirtualHosts
    [Tue Dec 28 09:31:01 2010] [warn] NameVirtualHost 180.151.50.116:443 has no VirtualHosts
    [Tue Dec 28 09:31:03 2010] [warn] NameVirtualHost 180.151.50.116:443 has no VirtualHosts

    Server: Debweb.webdesignerschennai.com (Debian Lenny)
    ISPConfig 3.0.3.1
    State: ok (0 unknown, 0 info, 0 warning, 0 critical, 0 error)
    ok:
    The state of your Hard-Disk space is ok [More...]
    Your virus protection is ok [More...]
    Your Mail queue load is ok [More...]
    Your Server load is ok [More...]
    All needed services are online [More...]
    Your system is up to date. [More...]
    The System Log is O.K. [More...]
     
    Last edited: Dec 28, 2010
  6. jacksmerv

    jacksmerv New Member

    do i have to add the path in Apache Directives to activate my domains ?
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    no.

    Is the server behind a router?
     
  8. jacksmerv

    jacksmerv New Member

    yes it is behind a watchguard firewall x550e
     
  9. jacksmerv

    jacksmerv New Member

    Thanks Till,
    I have connected my server without firewall and it is working fine. one thing is missing my webmail... It gives me 404 error. What could me the problem? please help ...

    Another thing if i connect through my hardware firewall how should configure my ISPconfig according to that. please guide me. Thanks in advance.
     

Share This Page