Virtual Hosts not working, feisty perfect setup

Discussion in 'General' started by j.turner, Apr 23, 2007.

  1. j.turner

    j.turner New Member

    I did the feisty perfect server setup guide, twice, command by command.
    The humble server is a HP celeron 1gig 2ghz Ubuntu feisty fawn

    Each time I setup the server, everything appears to be ok, but all created sites point to the first created site.

    I made a new client "justin"
    New website (dns yes)
    Everything looks fine, welcome page is hooked up.
    Justin > new website (dns yes)

    Both sites point to the same directory. ('s) i have the php info()

    What is wrong?!

    *update, I deleted unlimited-memories, emptied recycle bin, and ispconfig crashed. I tried to reboot it, nothing. I am under a cisco router, but I put it in the DMZ, so no ports are blocked.

    *setup - godaddy domain ns is = is the troubled dns server. The sites are hosted on the same machine.
    Dns report for
    Last edited: Apr 23, 2007
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    1) Has the website a co domain with empty hostname? If not, create it.

    2) does the domain point to the IP address of your server? You will have to wait up to 48 hours until DNS chnages, so dont expect that a change in DNS is visible instantly!

    3) You muts connect to the website by domain adn not IP address.
  3. j.turner

    j.turner New Member

    Created codomain

    I created a codomain with no hostname.
    The domain has been pointing towards the dns server for over 2 weeks.

    Now points towards my root directory /var/www
    Now points towards it also.

    One thing to note is that the dns server is also the web server.
  4. j.turner

    j.turner New Member


    I fixed it it by changing the server ip in management > settings to it's internal ip.
    Then the a record to the server internal ip.

    I don't think ispconfig is clear about what ip to put in, but perhaps I'm probably just too new to understand. Thanks for your help!

    Now time to hook up ruby on rails to it. :( :rolleyes:

Share This Page