Discussion in 'HOWTO-Related Questions' started by Lord_Garfield, Apr 30, 2013.

  1. Lord_Garfield

    Lord_Garfield New Member


    I followed the tutorial:

    But instead of centos 6.2 I have 6.3.

    I also had to make a few changes for folowing reasons:

    I have a /ierp/www/ierp folder wich has a "ln -s /ierp/www/ierp /var/www/html"
    Becouse this will be my webroot

    I want one user to have ftp access to /ierp/www
    So in mysql database I have /ierp/www as homedir for that user.

    mysql is also moved to /ierp/mysql and my socket is set to
    MYSQLSocket /ierp/mysql/mysql.sock

    mysql works fine after the replace (Owncloud is working on this server)

    I also changed the bind parameter,21 to,10021
    I listen on port 10021.
    (And I opened this port in the firewall ofcource)

    Now when I connect to the ftp server
    and I loggin with the username and password wich I created in the database.
    It will login but I gives me the error that It can't open folderlist (this could be a bad translation of "Kan de mappenlijst niet openen")

    I changed rights on the www folder like this:

    groupadd ierp
    usermod -a -G ierp apache
    usermod -a -G ierp ftpuser
    chown apache:ierp /ierp/www/ierp

    Same result.

    What did I do wrong?
  2. Lord_Garfield

    Lord_Garfield New Member

    Issue solved.

    I forgot that it is passive FTP. So I opened the port range 30000:50000 and uncommented the passive port range in the config file. Now it all works!


Share This Page