virtual host problem

Discussion in 'Installation/Configuration' started by gabykh, Jul 6, 2009.

  1. gabykh

    gabykh New Member

    Hello ,
    I have installed ispconfig ( last version ) on Centos5.3 as the tutorial of HowtoForge instructed .
    I have faced the following problem :

    First I created a client and under this client I created a new website for - I uploaded the files to the server of that domain and the website works excellent - with no errors :)

    When I tried to add another website on the server , i.e I created a new website for - I faced a problem :
    The first website with the domain now point to the new site with the default page .
    When I delete the new site the problem solved .

    I am not able to host more than one website on the server ,has anyone faced such a problem ? Can anyone please help me ?

    Thanks in advance :)
    Last edited: Jul 6, 2009
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    1) Make sure that you create both sites as individual sites and not as alias or subdomian.
    2) Make sure that both domains really exist in dns and have a dns A-Record pointing to your server.
    3) If you want to access the domain also with, make sure that you enable auto subdomain www in the site settings.
  3. gabykh

    gabykh New Member

    Thanks for your reply

    Thanks till for your reply :)
    I have re-checked your 3 points and I found that I have already configured the setting of those 3 points as you mentioned .
    Still have the problem ( nothing changed ) !

    When I add a new site ( not a subdomain ) all the websites that are already configured in the server ( through ispconfig ) will point to that site !

    Can you help me ? I am very much desperate and don't have a clue on the problem !

    Thanks in advance ,
    Last edited: Jul 7, 2009
  4. dzudzu

    dzudzu New Member

    Well for a start i would check in /etc/httpd/conf/sites-enabled does there exist .vhost file for every site u made? and when u open them does it properly gets filled ServerName and ServerAlias?

    also check just to be sure /etc/httpd/conf/httpd.conf that there is line at end of file

    Include /etc/httpd/conf/sites-enabled/

Share This Page