Virtual Host - IP Address / Domain Name

Discussion in 'Installation/Configuration' started by mintman, May 22, 2009.

  1. mintman

    mintman New Member

    Hi, I have ISPConfig 3.0.1.1 up and running with a number of sites and everything works great - except...

    When I setup a new site - on the website options page next to IP address there is only * in the drop down.

    After setting up the site, and going to www.domain.com I just get the apache2 test page "It Works"

    I then need to go into the .vhost file in the apache2/sites-enabled directory and change the line

    <VirtualHost *:80>
    to
    <VirtualHost www.domain.com:80>

    I then need to restart apache and the site works

    Sure there is something I have missed. It would great not to edit vhost files manually and have to restart apache everytime a new site is added

    Thanks for any help
     
  2. till

    till Super Moderator

    Just select the IP address for the domain instead of * in the site settings and click on save.
     
  3. mintman

    mintman New Member

    Thanks for getting back on this

    I only had a * in the dropdown next to IP address in the site config page

    So I added the IP address in the System, Server IP address field

    Then went back to the site config and selected the IP address, clicked save, restarted Apache, then on navigating to the site I got the "It Works" page.

    Waited 2 minutes, reloaded the site and the site loads correctly

    Thanks for you help - knew it had to be something obvious!
     
  4. da_Fohz

    da_Fohz New Member

    Well, since this isn't closed, I'll hop on the topic to try and sort out my problem.

    My problem is barely the same:

    I freshly installed ISP Config 3.0.1.6 and just created a new website (pic 1)

    http://img514.imageshack.us/i/newwebsite.jpg/

    My dns records

    http://img136.imageshack.us/i/dnsrecords.jpg/

    Finally, my apache vhosts as seen on webmin:

    http://img705.imageshack.us/i/apacheconf.jpg/


    Whenever I visit my website, either via its domain name (including webmail., www., mail.), via its external ip or via its lan ip, it always comes up the default apache webpage "It Works!"

    I have been reading posts and suggestions for over 4h and nothing seems to work.

    Can you please help me on this? Isn't ISPConfig supposed to do it automatically?

    Thanks
     
    Last edited: Feb 21, 2010
  5. da_Fohz

    da_Fohz New Member

    Help, anyone?
     
  6. till

    till Super Moderator

    1) Do not use webmin on the same server where you installed ispconfig as this might corrupt your setup and results in non working sites and email domains.

    2) You selected the wrong IP in the website settings. Your system is behind a router, this means that you have to use the external IP in the dns settings and the internal IP in the website settings, but you used the external IP in the website settings too.
     
  7. da_Fohz

    da_Fohz New Member

    Thanks for the help Till.

    Changing the IP did it perfectly.
    The interface should have a better description there, or a "hover help" specifying which IP should be used.
     

Share This Page