virtual domains do not receive email

Discussion in 'Server Operation' started by hvrossum, Mar 23, 2009.

  1. hvrossum

    hvrossum New Member

    Hi,

    Somehow my virtual domains are not receiving emails in Postfix, I have looked through every step of the How to (Ubuntu with ISPConfig setup) but somehow I cannot find what I have done wrong.

    When I dig mx agnitio.nl I get following response

    ; <<>> DiG 9.4.2-P2 <<>> mx agnitio.nl
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 27158
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;agnitio.nl. IN MX

    ;; ANSWER SECTION:
    agnitio.nl. 86400 IN MX 10 82.95.205.252.

    ;; Query time: 18 msec
    ;; SERVER: 192.168.1.254#53(192.168.1.254)
    ;; WHEN: Mon Mar 23 10:03:15 2009
    ;; MSG SIZE rcvd: 57

    The MX record is the correct IP

    Mail error log gives this:
    Mar 22 12:29:36 ubuntu freshclam[5942]: Can't get information about database.clamav.net: Name or service not known
    Mar 22 16:35:38 ubuntu postfix/sendmail[17663]: fatal: usage: sendmail [options]
    Mar 22 16:36:17 ubuntu postfix/sendmail[20112]: fatal: usage: sendmail [options]
    Mar 22 16:36:29 ubuntu sendmail[20930]: NOQUEUE: SYSERR(root): /etc/mail/sendmail.cf: line 0: cannot open: No such file or directory
    Mar 23 09:32:14 ubuntu postfix/master[19070]: fatal: bind 0.0.0.0 port 25: Address already in use
    Mar 23 09:33:48 ubuntu postfix/postqueue[19384]: fatal: Cannot flush mail queue - mail system is down
    Mar 23 09:33:58 ubuntu postfix/master[19549]: fatal: bind 0.0.0.0 port 25: Address already in use
    Mar 23 09:34:40 ubuntu postfix/postqueue[19750]: fatal: Cannot flush mail queue - mail system is down
    Mar 23 09:34:48 ubuntu postfix/master[19914]: fatal: bind 0.0.0.0 port 25: Address already in use
    Mar 23 09:34:55 ubuntu postfix/master[20074]: fatal: bind 0.0.0.0 port 25: Address already in use
     
  2. falko

    falko Super Moderator ISPConfig Developer

    What's in your main.cf? Which ISPConfig version is installed?
     

Share This Page