Viewing awstats

Discussion in 'Installation/Configuration' started by bswinnerton, Aug 6, 2007.

  1. bswinnerton

    bswinnerton New Member

    I've successfully installed awstats but now i am having some troubles.

    Whenever i try to view the index.php it says 500 internal server error and if i look in my log i am getting

    [error] an unknown filter was not added: PHP

    can anyone help?
  2. torusturtle

    torusturtle ISPConfig Developer ISPConfig Developer

    Did you add the php extension to apache configuration file?
    Does this problem happen also to other php files on the same domain or just awstat?
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    I guess you looked in the wrong logfile. You must have a look in the error log of the website and not in the global error log to see what caused the 500er error.
  4. bswinnerton

    bswinnerton New Member

    It only happens to awstats. And what error log are you talking about? Where can I find it?

  5. TomTom80

    TomTom80 New Member

    Similar problem with awstat

    I have installed awstats too and if I try get I am asked for username and password and afterthat I get error 403

    in error log is:
    [Tue Aug 07 16:08:24 2007] [error] [client] client denied by server configuration: /usr/share/awstats/wwwroot/cgi-bin/

    I tried change /etc/httpd/conf.d/awstatsreport.conf
    line "Allow from" to "Allow from All", but it doesn't help

    I run it on Fedora and I did perfect setup

    Can my anyone help?
  6. TomTom80

    TomTom80 New Member

    It's better but not goal

    After this change
    I can get statistics on
    but on a get error 403 and in error log is
    I think that it's mean that I'm forwarded into /home/admispconfig/ispconfig/tools/awstats/wwwroot/cgi-bin/ instead get index.php from /var/www/web10/web/awstats/

    Have anyone any idea?

    P.S. If I copy files from /awstats into another directory it shows well

    Thanks for any help

  7. jnsc

    jnsc rotaredoM Moderator

    TomTom80 if you can see the logs with I think you are not using the AWStats with static pages as described in the "HowTo Install AWStats With Some PlugIns On A Server With ISPConfig" Page located at I don't know the other one (dynamic stats) so I can not help you, but you might post your question on this thread

    bswinnerton did you enable php for this website? I know it was kind of stupid that I made a static stats script which requires something dynamic (PHP). But I will work this out for the next version. It was sitting on my todo list for quite some time, but I just didn't found the time yet to do it.

  8. bswinnerton

    bswinnerton New Member

    I'm not sure if i enabled php for the site, do you mean through ispconfig? If so, yes php scripts is checked.

    Plus my homepage is in php, so I would believed that it is.

    But I cannot get to like everyone else can, I still get the 500 error.
  9. TomTom80

    TomTom80 New Member

    It's done

    Hi Jonas,

    you helped me alot:)

    I'm not sure what is reason of my configuration (probably I have selected during instalation), but I have /etc/httpd/conf.d/awstats.conf which overtake control on all /awstats ..... I have renamed this file to awstats.conf.STOP and restart httpd and after this it shows generated files:D

  10. bswinnerton

    bswinnerton New Member

    Okay so my homepage is in php but i still cannot view I get a 500 error from ispconfig.

    Can someone please help?
  11. jnsc

    jnsc rotaredoM Moderator

    Please post the content of the error log of your website (/var/www/webX/log/error.log)
  12. bswinnerton

    bswinnerton New Member

    Ah ha.

    I was looking at the wrong error log, when you referred me to that one, i was able to fix the problem.

  13. jnsc

    jnsc rotaredoM Moderator

    Your welcome, but I must give the credits back to Till, because he posted the solution first.
  14. bswinnerton

    bswinnerton New Member

    I know i've seen this brought up before. But how come the bars aren't colored?
  15. jnsc

    jnsc rotaredoM Moderator

    Last edited: Aug 10, 2007
  16. bswinnerton

    bswinnerton New Member

    The lastest one on your website..
  17. jnsc

    jnsc rotaredoM Moderator

    I was talking about your Linux distribution. Debain, Ubuntu?
  18. bswinnerton

    bswinnerton New Member

    Oh, i'm sorry. Yes, Ubuntu.
  19. bswinnerton

    bswinnerton New Member

    Okay i figured it out, i changed my apache2.conf to say

    Alias /icon "/home/admispconfig/ispconfig/tools/awstats/wwwroot/icon/"

    And then realized that didn't do anything so i found out that the bars are actually looking in the root directory /icon, so i just made a link to the awstats folder in admispconfig, and that solved it. Maybe it was my fault, but should it have done that itself?

Share This Page