viewing a htaccess file in the ftp

Discussion in 'Installation/Configuration' started by Boon-Dog-Danny, Aug 3, 2006.

  1. Boon-Dog-Danny

    Boon-Dog-Danny New Member

    I have noticed I can not see or access any of the htaccess files I have in my files. is there a way to do this? I have tried both the web based ftp and a client ..wsftp.. and filezilla neither show the htaccess files on this server but show the files on my other server.. can I adjust a file so I can view the htaccess files?

    thanks
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please have a look at your proftpd.conf file, it seems that you configured proftpd to hide files that begin with a dot.
     
  3. Boon-Dog-Danny

    Boon-Dog-Danny New Member

    Till its me Danny.. ;) a.k.a.. I have no idea what I'm doing.. ;)

    that means I have no idea what I'm looking for bro. I looked at the file and it dont say anything about htaccess, can you give me instructions?

    this is what I got Till.. from the terminal window.. I used the create this page below when I installed the proftp



    server1:/home/admin # vi /etc/proftpd.conf
    # at once, simply increase this value. Note that this ONLY works
    # in standalone mode, in inetd mode you should use an inetd server
    # that allows you to limit maximum number of processes per service
    # (such as xinetd).
    MaxInstances 30

    # Set the user and group under which the server will run.
    User nobody
    Group nogroup

    # To cause every FTP user to be "jailed" (chrooted) into their home
    # directory, uncomment this line.
    DefaultRoot ~
    IdentLookups off
    ServerIdent on "FTP Server ready."
    # Normally, we want files to be overwriteable.
    AllowOverwrite on

    # Bar use of SITE CHMOD by default
    #<Limit SITE_CHMOD>
    # DenyAll
    #</Limit>

    # A basic anonymous configuration, no upload directories. If you do not
    # want anonymous users, simply delete this entire <Anonymous> section.
    <Anonymous ~ftp>
    User ftp
    Group ftp

    # We want clients to be able to login with "anonymous" as well as "ftp"
    UserAlias anonymous ftp

    # Limit the maximum number of anonymous logins
    MaxClients 10

    # We want 'welcome.msg' displayed at login, and '.message' displayed
    # in each newly chdired directory.
    DisplayLogin welcome.msg
    DisplayFirstChdir .message

    # Limit WRITE everywhere in the anonymous chroot
    <Limit WRITE>
    DenyAll
    </Limit>
    </Anonymous>


    *****************************************
    used this file at the creation from perfect setup 10.1 suse.. /etc/init.d/proftpd
    ****************************************
    #! /bin/sh
    # Copyright (c) 2000-2001 SuSE GmbH Nuernberg, Germany.
    # All rights reserved.
    #
    # Original author: Marius Tomaschewski <mt@suse.de>
    #
    # Slightly modified in 2003 for use with SuSE Linux 8.1,
    # by http://www.learnlinux.co.uk/
    #
    # Slightly modified in 2005 for use with SuSE Linux 9.2,
    # by Falko Timme
    #
    # /etc/init.d/proftpd
    #
    ### BEGIN INIT INFO
    # Provides: proftpd
    # Required-Start: $network $remote_fs $syslog $named
    # Required-Stop:
    # Default-Start: 3 5
    # Default-Stop: 0 1 2 6
    # Description: Starts ProFTPD server
    ### END INIT INFO

    # Determine the base and follow a runlevel link name.
    base=${0##*/}
    link=${base#*[SK][0-9][0-9]}

    # Force execution if not called by a runlevel directory.
    test $link = $base && START_PROFTPD=yes # Modified by learnlinux.co.uk
    test "$START_PROFTPD" = yes || exit 0 # Modified by learnlinux.co.uk

    # Return values acc. to LSB for all commands but
    # status (see below):
    #
    # 0 - success
    # 1 - generic or unspecified error
    # 2 - invalid or excess argument(s)
    # 3 - unimplemented feature (e.g. "reload")
    # 4 - insufficient privilege
    # 5 - program is not installed
    # 6 - program is not configured
    # 7 - program is not running

    proftpd_cfg="/etc/proftpd.conf"
    proftpd_bin="/usr/local/sbin/proftpd"
    proftpd_pid="/usr/local/var/proftpd.pid"

    [ -r $proftpd_cfg ] || exit 6
    [ -x $proftpd_bin ] || exit 5

    # Source status functions
    . /etc/rc.status

    # First reset status of this service
    rc_reset

    case "$1" in
    start)
    echo -n "Starting ProFTPD Server: "
    test -f /etc/shutmsg && rm -f /etc/shutmsg
    /sbin/startproc $proftpd_bin
    rc_status -v
    ;;

    stop)
    echo -n "Shutting down ProFTPD Server: "
    test -x /usr/local/sbin/ftpshut && /usr/local/sbin/ftpshut now && sleep 1
    /sbin/killproc -TERM $proftpd_bin
    test -f /etc/shutmsg && rm -f /etc/shutmsg
    rc_status -v
    ;;

    restart)
    ## If first returns OK call the second, if first or
    ## second command fails, set echo return value.
    $0 stop
    $0 start
    rc_status
    ;;

    try-restart)
    ## Stop the service and if this succeeds (i.e. the
    ## service was running before), start it again.
    ## Note: not (yet) part of LSB (as of 0.7.5)
    $0 status >/dev/null && $0 restart
    rc_status
    ;;

    reload|force-reload)
    ## Exclusive possibility: Some services must be stopped
    ## and started to force a new load of the configuration.
    echo -n "Reload ProFTPD Server: "
    /sbin/killproc -HUP $proftpd_bin
    rc_status -v
    ;;

    status)
    # Status has a slightly different for the status command:
    # 0 - service running
    # 1 - service dead, but /var/run/ pid file exists
    # 2 - service dead, but /var/lock/ lock file exists
    # 3 - service not running
    echo -n "Checking for ProFTPD Server: "
    checkproc $proftpd_bin
    rc_status -v
    ;;

    probe)
    ## Optional: Probe for the necessity of a reload,
    ## give out the argument which is required for a reload.
    [ $proftpd_cfg -nt $proftpd_pid ] && echo reload
    ;;

    *)
    echo "Usage: $0 {start|stop|status|restart|reload|try-restart|probe}"
    exit 1
    ;;
    esac

    # Set an exit status.
    rc_exit
     
    Last edited: Aug 3, 2006
  4. falko

    falko Super Moderator ISPConfig Developer

    Add this to /etc/proftpd.conf:

    Code:
    LsDefaultOptions                "-la"
    and restart ProFTPd.
     
  5. Boon-Dog-Danny

    Boon-Dog-Danny New Member

    server1:/home/admin # /etc/init.d/proftpd restart
    Shutting down ProFTPD Server: done
    Starting ProFTPD Server: - Fatal: unknown configuration directive 'LsDefaultOptions' on line 25 of '/etc/proftpd.conf'
    startproc: exit status of parent of /usr/local/sbin/proftpd: 1
    failed
    server1:/home/admin #


    did not work..
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Then try this instead in /etc/proftpd.conf:
    Code:
    ListOptions                     "-la"
     
  7. Boon-Dog-Danny

    Boon-Dog-Danny New Member

    no error this time but still no .htaccess files anything else I can try?

    and thanks falko
     
  8. phython

    phython New Member

    in my config i have this ... and i can see htaccess file ))
     
  9. Boon-Dog-Danny

    Boon-Dog-Danny New Member

    thanks.. but still no..
     
  10. phython

    phython New Member

    whats the output of #uname -a
    do you use ispconfig ?

    then try to add this to the config:

     
  11. Boon-Dog-Danny

    Boon-Dog-Danny New Member

    I figured out how to edit the .htaccess files now thru the terminal window..so I'm not dead in the water, but if anyone can think of a way to get these to show in my ftp client that would be great.
     
  12. Boon-Dog-Danny

    Boon-Dog-Danny New Member

    #uname -a in the terminal window does nothing.. maybe I should clear this up now.. I have no.. thats zero idea can you give me the command.. is this

    #uname -a .. is that what I type in the terminal? I can just barely nav that thing.. and have really no idea just picking up the basics of how and where stuff is nav-ing thru the terminal window ..exploring helps.. but I edit! if you just point me to the correct file .. and thanks TONS!!
     
  13. falko

    falko Super Moderator ISPConfig Developer

    Are you sure you're in the correct directory (the one the .htaccess file is in) when you use FTP?
     
  14. Boon-Dog-Danny

    Boon-Dog-Danny New Member

    yes, correct directory, I just double checked, and seen the .htaccess files in the terminal window..

    server1:/srv/www/web1/web # cd admin
    server1:/srv/www/web1/web/admin # ls
    case .htaccess index.html language links modules
    server1:/srv/www/web1/web/admin #

    still can not see it , but I hear the suse is not the best so i'm taking a system developers input and changing versions what do you think would be the best version to use? for a few personal web sites and personal mail setup?
     
  15. falko

    falko Super Moderator ISPConfig Developer

    Debian. :)
     
  16. Boon-Dog-Danny

    Boon-Dog-Danny New Member

    YOU ROCK!!! I can see the files.. but now another question.. I've noticed the htaccess dont seem to be working correctly, I get 500 internal server errors or 403 any ideas?
     
  17. till

    till Super Moderator Staff Member ISPConfig Developer

    Please check the sntyx of your htaccess file. Maybe you use a function that is not allowed in .htaccess by the "AllowOverride" directive in your apache configuration.
     
  18. Boon-Dog-Danny

    Boon-Dog-Danny New Member

    Thanks Till My stuff works GREAT!!!! im very happy, big thanks to all you guys and gals for all your help!

    yup I read a few other forums on the apache 500 error and poof.. im set up..lol

    Hey I only have one other question on this server.. now everything is fine.. working .. basicly.. I have two little errors that I think are registered globals troubles my php.ini file, I have the info.php page up so I can see where and whats on.. I see it has two rows..
    Local Value Master Value
    the master is correct the local value

    safe_mode On Off

    how or I should say where do I change the local values?
     
  19. falko

    falko Super Moderator ISPConfig Developer

    Might be in your .htaccess file or in your vhost configuration, and if it's not there, it's in php.ini.
     
  20. Boon-Dog-Danny

    Boon-Dog-Danny New Member

    thanks.. ;) I will find this today!!
     

Share This Page