view website

Discussion in 'General' started by viro, Sep 15, 2010.

  1. viro

    viro New Member

    Hi, I wanted to ask about creating a site with ISPConfig.
    That is when I create a site I create folders in www.
    A web folder is the folder where the file is index.html

    But when you step away broswer at the site I created apprare all folders contained within the web folder, but not the index.html file.

    Example: step away broswer to this address:
    see this:

    [DIR] Parent Directory -
    [DIR] cgi-bin/ 15-Sep-2010 00:07 -
    [DIR] log/ 15-Sep-2010 00:07 -
    [DIR] ssl/ 15-Sep-2010 00:07 -
    [DIR] tmp/ 15-Sep-2010 00:07 -
    [DIR] web/ 15-Sep-2010 00:07 -

    So to see the site I write like this:

    where (should be my hypothetical ip)

    I hope I have been clear enough.

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Website paths in ISPConfig are like this:


    The path never contains an IP address. For easier navigation, ISPConfig creates also a symlink with the domain name of a website in var/www.
  3. viro

    viro New Member

    Thanks for your answer, I'll explain I created a site called

    Now I go to this address containing my ip address with the site:

    and I always see the same screen
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    You have to access the website by domain name and not IP address. So to access the website, open a webbrowser and enter:

    into the address field.
  5. viro

    viro New Member

    I created a hypothetical domain, I'm trying to see if everything works properly, before they enter a domain above.
    To reach this folder by IP address.
  6. till

    till Super Moderator Staff Member ISPConfig Developer

  7. viro

    viro New Member

    Thanks for your help, but I still can not, I'll explain what I did following the guidance that I have indicated:
    (Forgive me if I say something stupid, but then again I'm new to this thing)

    I created a site called in ISPConfig.
    I went in ISPConfig DNS section
    Then add New DNS Zone (SOA) and I added Zone (SOA), then I entered NS, then went into the TAB "Records" and I added the "A" as the hostname "www. "then I entered my ip address of the server I checked on active and I have saved.
    Finally I added this line in / etc / hosts

    Then I combed apache, but nothing.

    What's wrong?

  8. till

    till Super Moderator Staff Member ISPConfig Developer

    1) Create the website with the domain and not and select auto subdomain www in the website settings.
    2) You dont need the dns record.
    3) You have to edit the hosts file on your workstation as described in the FAQ and not the server. A hosts file is available on all common operating systems (windows, MAC and Linux).
  9. viro

    viro New Member

    Ok, thanks it works.

Share This Page