Video Script

Discussion in 'Installation/Configuration' started by tbctr, May 24, 2014.

  1. tbctr

    tbctr Member

    The Perfect Server - Debian Wheezy (nginx, BIND, Dovecot, ISPConfig 3) installed no problem. One web site running. I will use to store video. sample: I create my own YouTube clone vs. Which would you recommend script, clone ? I would like to get suggestions. Thanks
     
  2. tbctr

    tbctr Member

  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Ensure that you added the phpshield in all php.ini files:

    /etc/php5/apache2/php.ini
    /etc/php5/cgi/php.ini
    /etc/php5/fpm/php.ini

    and then restart apache and php-fpm.
     
  4. tbctr

    tbctr Member

  5. tbctr

    tbctr Member

    wiki page : "you will get a path something like /usr/lib/php/extensions/no-debug-non-zts-20060613. Now enter this directory
    cd /usr/local/lib/php/extensions/no-debug-non-zts-20060613"

    My installation : /usr/lib/php5/20100525
    no folder "extensions"

    Added files and php.ini but error :
    Warning: realpath(): open_basedir restriction in effect. File(/usr/lib/php5/20100525) is not within the allowed path(s): (/var/www/clients/client1/web1/web:/var/www/clients/client1/web1/private:/var/www/clients/client1/web1/tmp:/var/www/sunucu.******.net/web:/srv/www/sunucu.*******.net/web:/usr/share/php5:/usr/share/php:/tmp:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/lib/phpmyadmin) in /var/www/clients/client1/web1/web/classes/config.php on line 2
    extension_dir does not exist: /usr/lib/php5/20100525
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Add /usr/lib/php5/20100525 to the open_baesdir path on the options page of the website.Paths are separated by :
     
  7. tbctr

    tbctr Member

    Now error : PHP script /var/www/clients/client1/web1/web/classes/config.php is protected by phpSHIELD and requires the phpSHIELD loader ixed.5.4.lin. The phpSHIELD loader has not been installed, or is not installed correctly. Please find the required loader within phpSHIELD installation directory or visit the phpSHIELD php encoder site to download it. :( :eek:
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Do you use the default php version? If yes, are absolutely sure that you installed it in the file /etc/php5/fpm/php.ini and that you restarted php-fpm afterwards?
     
  9. tbctr

    tbctr Member

    MySQL
    Sunucu: Localhost via UNIX socket
    Sunucu sürümü: 5.5.37-0+wheezy1
    Protokol sürümü: 10
    Kullanıcı: [email protected]
    MySQL karakter grubu: UTF-8 Unicode (utf8)

    Web sunucusu
    nginx/1.2.1
    MySQL istemci sürümü: 5.5.37
    PHP uzantısı: mysqli Belgeler

    phpMyAdmin
    Sürüm bilgisi: 3.4.11.1deb2
     
  10. tbctr

    tbctr Member

  11. till

    till Super Moderator Staff Member ISPConfig Developer

    install a additional older php version. see instructions on ispconfig.org documentation page.
     
  12. tbctr

    tbctr Member

    Till, run it on another system. Thanks a lot.

    Only one problem, need nginx directives. (Links 500 internal server error. )
     
  13. tbctr

    tbctr Member

    After a long break I tried to make this setup again.
    1. The Perfect Server - Debian Wheezy (nginx, BIND, Dovecot, ISPConfig 3) install.
    2. How To Use Multiple PHP Versions (PHP-FPM & FastCGI) With ISPConfig 3 (Debian Wheezy) only page 1 install 5.3.22.
    3. Ispconfig panel sites php-fpm 5.3.22 selected. Phpmotion files upload and step 2 error:
    Checking if PHPshield encoded files are working Error! - See detailed explanation below.
    Causes & Solutions
    Your server isPHP5.3+and from this version onwards, PHPshield loaders need to be installed directly on the server (in the php extensions directory).
    Solution:
    If you have a dedicated server of VPS, you canview our instructions http://wiki.phpmotion.com/PHPShield53
    I did this instructions but again error. Now formatting server step 1,2,3. How do install PHPshield ?
     
  14. till

    till Super Moderator Staff Member ISPConfig Developer

    No need to format the server as your problem is only in the custom php version / phpshield loader combination. Are you sure that you installed phpshield in the correct php.ini file, the one of the php 5.3 version? Add a info.php test file in the website and check if phpshield shows up in the phpinfo() function output. There you see also the php.ini file where it has to be added.

    The instructions from phpshield above are not correct for your server as they install phpshiuld in the main php version of the linux distribution and not into the manually compiled php 3, so the paths need to be altered to match your php location.
     
  15. tbctr

    tbctr Member

  16. till

    till Super Moderator Staff Member ISPConfig Developer

    Is there a php.ini file in /opt/php-5.3.22/lib/ directory? Have you set the php.ini file directory to /opt/php-5.3.22/lib for this php version in ISPconfig?
     
  17. tbctr

    tbctr Member

    php 5.3.22 php.ini file yes /opt/php-5.3.22/lib/ directory. Other php.ini file /etc/php5/cli directory.
    ISPConfig 3.0.5.4p5
     
  18. tbctr

    tbctr Member

  19. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok, an you configured phpshield in the file /opt/php-5.3.22/lib/php.ini ?
     
  20. tbctr

    tbctr Member

    http://wiki.phpmotion.com/PHPShield53
    Step 5 - Edit your php.ini file

    First you need to find out the location of your main php.ini file. This file is the main configuration file for PHP on your server.
    You do this by typing the command below
    php -i|grep php.ini
    You should get a result that shows something like this
    Loaded Configuration File => /etc/php.ini
    In the case of our example above, the path we want it /etc/php.ini
    Now run the command below. Remember to use your own php.ini directoy path in the command above

    echo "extension=ixed.5.3" >> /etc/php.ini
    echo "extension=ixed.5.3" >> /opt/php-5.3.22/lib/php.ini
    I tried both of them, again error
    http://i.hizliresim.com/NVGMZX.png
     

Share This Page