vhosts_ispconfig weirdness

Discussion in 'General' started by iverson0881, Jan 20, 2007.

  1. iverson0881

    iverson0881 New Member

    So basically when I access my server for the first time www.glerck.com I get a directory listing of /var/www/ once I create a site it then gives me the welcome to www.glerck.com. I don't believe this was the behavior. Also when I manually type in the server IP...8.14.146.162 it shows /var/www/ unless I create a site under ISPConfig. I also have 8.14.146.163-6. Which also observe this behavior. I try adding the following lines my vhosts_ispconfig:

    Code:
    NameVirtualHost 8.14.146.162:80
    <VirtualHost 8.14.146.162:80>
      ServerName localhost
      ServerAdmin [email protected]
      DocumentRoot /var/www/sharedip
    </VirtualHost>
    NameVirtualHost 8.14.146.163:80
    <VirtualHost 8.14.146.162:80>
      ServerName localhost
      ServerAdmin [email protected]
      DocumentRoot /var/www/sharedip
    </VirtualHost>
    NameVirtualHost 8.14.146.164:80
    <VirtualHost 8.14.146.162:80>
      ServerName localhost
      ServerAdmin [email protected]
      DocumentRoot /var/www/sharedip
    </VirtualHost>
    NameVirtualHost 8.14.146.165:80
    <VirtualHost 8.14.146.162:80>
      ServerName localhost
      ServerAdmin [email protected]
      DocumentRoot /var/www/sharedip
    </VirtualHost>
    NameVirtualHost 8.14.146.166:80
    <VirtualHost 8.14.146.162:80>
      ServerName localhost
      ServerAdmin [email protected]
      DocumentRoot /var/www/sharedip
    </VirtualHost>
    but it hasn't seemed to take any effect. Do you know whats up?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Have you added all the IP addresses 8.14.146.163-6 within ISPConfig under management > server settings?
     
  3. iverson0881

    iverson0881 New Member

    Yes they were already there when I first loaded up ISPConfig
     
  4. iverson0881

    iverson0881 New Member

    is there a list somewhere of all the files ispconfig touches and/or creates
     
  5. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

    Apache2 has a default site in /var/www and you need to modify /etc/apache2/sites-available/default to get rid of the standard Directory listing. ISPConfig already has the right settings/files to show a warning to people accessing the IP about a shared IP usage.

    Change the parts related to /var/www in the file mentioned above to
    Code:
    .....<snipped>
           <Directory /var/www/>
                    [COLOR="DarkRed"]Options -Indexes FollowSymLinks MultiViews
                    AllowOverride None[/COLOR]
                    Order allow,deny
                    allow from all
                    # Uncomment this directive is you want to see apache2's
                    # default start page (in /apache2-default) when you go to /
                    #RedirectMatch ^/$ /apache2-default/
            </Directory>
    ......</snipped>
    
     
  6. falko

    falko Super Moderator ISPConfig Developer

    That's the normal behaviour.
    This is ok as well. After you have created a web site with ISPConfig you should get the Shared-IP page when you type in an IP address in your browser.
     

Share This Page