Discussion in 'Installation/Configuration' started by actiononline, Sep 26, 2006.

  1. actiononline

    actiononline New Member

    After the setup of ISPConfig and the transfer of all out client domains and mail accounts, I noticed that Mambo and other db applications don't want to run properly. Eventually I tracked the problem to the VHosts_ispconfig.conf file where it keeps adding two directives to all new virtual hosts added on the site.

    I amanually editied this file to comment out the two directives that was preventing Mambo to run
    # php_admin_flag safe_more On
    # php_admin_value open_basedit /var/www/web??/

    This then works fine untill I open ISPConfig and make any change on any of the domain, as it seems that ISPCOnfig then re-writes the VHosts_ispconfig.conf and removed the comments from all the sites to have php safe_mode on again and the open_basedit restriction on again for all the virtual domains.

    How to I stop this from happening, and maybe even if possible disable thise to directives on all current websites as well as future websites to be added?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    These directives where added, because you enabled PHP safemode in the website settings in ISPConfig. Uncheck the php safemode checkbox and safemode is disabled for the website.
  3. actiononline

    actiononline New Member

    Thank you for th4e response and advise. I did as you recommended, and it solved my problem ;)

    Thank you

Share This Page