Vhosts_ispconfig.conf unchanged

Discussion in 'Installation/Configuration' started by Tripple, Apr 19, 2011.

  1. Tripple

    Tripple New Member

    I try to change the domainname of a site with ISPConfig 2.2.35

    This is what I've done with ISP Manager:
    - Remove all users
    - Changed hostname and domainname
    - Save

    The new domainname is showing the shared IP error page, even after 24 hours waiting.

    When I looked at /etc/httpd/conf/vhosts/Vhosts_ispconfig.conf, no changes were made here. I know I shouldn't do this, but I changed the entries by hand, restarted httpd. Fixed.

    However, the error mails about quota limits are still showing the old domain. I guess I screwed up the database. How do I fix this?
     
  2. till

    till Super Moderator

    Are there any recent copies of the Vhost_ispconfig.conf file in the directory /etc/httpd/conf/vhosts/ with a date appended?
     
  3. Tripple

    Tripple New Member

    No, but there's a Vhost_ispconfig.conf~ file
     
  4. till

    till Super Moderator

    Try to restart the ispconfig server:

    /etc/init.d/ispconfig_server restart

    and check after a minute if changes get processed again.
     
  5. Tripple

    Tripple New Member

    Still no changes.
    Should I remove Vhost_ispconfig.conf~

    I've been doing some more testing and get this strange error when I try to add the old domain as co-domain:
    The name www.old.domain is already in use by another site or domain.
     
  6. till

    till Super Moderator

    Thats not nescessary. Try this command as root user on the shell:

    /root/ispconfig/php/php -q /root/ispconfig/scripts/writeconf.php

    Maybe it is still in the recycle bin. Please check all recycle bins while logged in as admin and empty them.
     
  7. Tripple

    Tripple New Member

    Empty the recycle bin! Of course. How could I forget about that.

    But the scripts gives me an error:
    Warning: fopen(): Filename cannot be empty in /root/ispconfig/scripts/lib/classes/ispconfig_file.lib.php on line 35
    start
    Segmentatiefout
     
  8. till

    till Super Moderator

    Which Linux distribution do you use?
    Have you installed any Linux updates like a update for BIND?
     
  9. Tripple

    Tripple New Member

    No updates.

    This is some info about the server:
    CentOS release 5.5 (Final)
    2.6.18-194.3.1.el5

    But it looks like bind is no longer there:
    # whereis bind
    bind: /usr/share/man/man2/bind.2.gz /usr/share/man/man3p/bind.3p.gz /usr/share/man/man1/bind.1.gz
     
  10. till

    till Super Moderator

    Ok, this explains the segfault error. Please take a look at the ispconfig 2 perfect setup for centos 5.5 and redo the steps of the bind installation chapter. Afterwards, retry the command from post #6 to see if the segfault is fixed.
     
  11. Tripple

    Tripple New Member

    Same error after the bind fix.
     
  12. till

    till Super Moderator

    Please check in ispconfig server settings if the bind directories are correct and match the directories of your installation.
     
  13. Tripple

    Tripple New Member

    It looks like there's a lot wrong with that server:
    Web:
    httpd.conf: /etc/apache2/apache2.conf -> This is an empty file
    httpd User: www-data -> Not there
    httpd Group: www-data -> Not there

    DNS:
    Named.conf: /etc/bind/named.conf -> not there
    ZoneFiles Dir: /etc/bind -> nope, not there

    I like to keep all settings and sites. No idea how this server got messed up like that. Is there a safe way to fix all this?
     
  14. till

    till Super Moderator

    Not sure, but is the apache config file on centos not named "httpd.conf" and not "apache2.conf"? In that case, it is ok that apache2.conf is empty.

    Regarding the http users, Do you have a backup of the passwd and group files where you can look up the correct lines?

    If you use a chrooted BIND, then the files are somewhere in /var/lib/named/...
     
  15. Tripple

    Tripple New Member

    Made all correct entries with the management tool.

    When I run the script
    /root/ispconfig/php/php -q /root/ispconfig/scripts/writeconf.php

    I get this:
    start
    ende

    However, the httpd config file ' /etc/httpd/conf/vhosts/Vhosts_ispconfig.conf' is still not populated with the changes from ISP Manager. I did found out that all changes are written to '/home/admispconfig/ispconfig/web/multidoc/edit/vhosts/Vhosts_ispconfig.conf'

    Do I have to wait some time before ispconfig writes these changes to the correct file or do I have to change another setting?
     

Share This Page