Vhosts_ispconfig.conf not updating

Discussion in 'General' started by Salvis, Oct 20, 2006.

  1. Salvis

    Salvis New Member

    After i updated ISPconfig from 2.2.6. to 2.2.7 i have problem.
    Every time i change something in ISP manager changes are written to new file, like: Vhosts_ispconfig.conf_20-10-06_18-15-50 but Vhosts_ispconfig.conf still have not updated...

    Every time i create new website i need to delete old Vhosts_ispconfig.conf and newly created file rename to Vhosts_ispconfig.conf.

    How to fix it?

    System: Fedora Core 5 64bit
     
    Last edited: Oct 20, 2006
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Make a backup of the file Vhosts_ispconfig.conf. Then rename Vhosts_ispconfig.conf_20-10-06_18-15-50 to Vhosts_ispconfig.conf and run:

    httpd -t

    and post the error here.
     
  3. Salvis

    Salvis New Member

    [[email protected] ~]# httpd -t
    [Sat Oct 21 12:48:18 2006] [warn] NameVirtualHost 195.244.128.88:80 has no VirtualHosts
    Syntax OK
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats ok so far. You can try and disable the httpd check feature in the file /home/admispconfig/ispconfig/lib/config.inc.php
     
  5. Salvis

    Salvis New Member

    Ok. I changed, but now is next problem. I need restart httpd manualy after i made any changes in ISP manager...
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Does Vhosts_ispconfig.conf update now? Do you see an error messages when you start Apache?
     
  7. Salvis

    Salvis New Member

    Yes, Vhosts_ispconfig.conf now updating.
    No special error messages except:

    [[email protected] ~]# /etc/init.d/httpd restart
    Stopping httpd: [ OK ]
    Starting httpd: [Mon Oct 23 11:44:51 2006] [warn] NameVirtualHost 195.244.128.88:80 has no VirtualHosts
    [ OK ]
     
  8. falko

    falko Super Moderator ISPConfig Developer

    That's just a warning, nothing serious, so ISPConfig should be able to restart Apache... :confused:
     

Share This Page