Vhosts_ispconfig.conf is Blank

Discussion in 'Installation/Configuration' started by learning, Nov 29, 2006.

  1. learning

    learning New Member


    I have a site down (dedicated server) for four days now because of a Hack and decided to fresh install Fedora 5 and ISPConfig as my control panel. After two days of fighting the ISPConfig installation (mainly because of MySQL root login problems) I am excited that I finally have an ISPConfig Control Panel, Yahoo !! But, after configuring my three personal websites I have yet another problem. I also use Webmin and noticed in the Apache module there is no mention of the newly created sites, there are also no folders created for the new sites anywhere. After taking a look at the Apache configuration file I noticed it references to "include" the " Vhosts_ispconfig.conf " file at the bottom. But when I take a look at the file I see it is totally "Blank", nada. Any ideas??

    Also, when I configure and/or update the " DNS Records " for the sites and " ISP Server Configuration " on the control panel I always get the errors below. I set both of the files mentioned to "777" and still get this error. Don't know if this is related to the above issue but I wanted to mention it.

    Can anyone please HELP ??? Any help would be appreciated I need to get my sites back up.

    Thank you,


    Error when configuring "Records"

    Warning: error_log(/home/admispconfig/ispconfig/ispconfig.log) [function.error-log]: failed to open stream: Permission denied in /home/admispconfig/ispconfig/lib/classes/ispconfig_log.lib.php on line 62

    Warning: Cannot modify header information - headers already sent by (output started at /home/admispconfig/ispconfig/lib/classes/ispconfig_log.lib.php:62) in /home/admispconfig/ispconfig/web/multidoc/edit/edit.php on line 360

    Note same errors in ISPConfig "Server Configuration"

    Warning: error_log(/home/admispconfig/ispconfig/ispconfig.log) [function.error-log]: failed to open stream: Permission denied in /home/admispconfig/ispconfig/lib/classes/ispconfig_log.lib.php on line 62

    Warning: Cannot modify header information - headers already sent by (output started at /home/admispconfig/ispconfig/lib/classes/ispconfig_isp_server.lib.php:158) in /home/admispconfig/ispconfig/web/multidoc/edit/edit.php on line 380
    Last edited: Nov 29, 2006
  2. coffeebeans

    coffeebeans New Member

    You havent mentioned which version of apache are you running along with ISPConfig is it apache2.x.x or apache1.3.x

    I had a similar issue where I installed apache2 as instructed on http://www.howtoforge.com/perfect_setup_ubuntu_6.06

    Then after intsalling ISPConfig I was getting the default holding page for apache1.3.34 so had to modify the web config under the management panel to instead use /etc/apache2/apache2.conf this got the sites up fine but then to further test the solution was stable I restarted the server and config has reverted back to the original config for ISPConfig install.

    Also on reboot apache2 doesnt startup at all, if you want a temperorary fix you can use the process I used but upon reboot if required for the server you might run into problem.

    If I find a solution I will post it here for you.
  3. learning

    learning New Member

    Blank Configuration file

    Thank you for responding. I'll look inot the temporarry solution you mentioned. I noticed that after 18 views I only received one response. Wonder if we're one of the rare ones. I will keep looking into it and report any progress as well.



    Oh, by the way, I'm using Fedora Core 5 and it comes with Apache v.2
  4. till

    till Super Moderator Staff Member ISPConfig Developer

  5. learning

    learning New Member

    Got It!!

    Thank you very much for responding. Well after three days at this, I actually gave up and deleted all respective files and databases. I re-installed and it actually fixed everything. I did notice the user and group names of the ISPConfig files were different this time around ("admipconfig" previously "root").

    Important: It is absolutely imperative that you have tested your "root" access and privleges to MySQL prior to starting the installation. If not, you'll pull your hair out like I did (eight hours of sleep in last three days). Would be nice if in the future the user can enter ALL the information needed so he/she can walk away from the installation and come back when it's done (about 20 minutes).

    Everything went smooth after that but I now have another problem, I can't see any of my new Websites!! It's another issue (#9) of which I will now investigate but I'm sure I'll figure out (hopefully).

    Would like to mention --- From what I have seen with the Control Panel, it looks like an excellent product. I commend the authors for doing a great job with the interface and making it user-friendly. I'm sure I'll be a long time supporter. Just would like to recommend on making the installation process less frustrating (finicky). Other than that, Great Job !!

    Best Rgds,

    Richard :eek:
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    We did it the other way round for a good reason. In most cases, the compilation of the packages fails for missing dependencies and the users complain about having entered all the information which gets lost when they had to start the setup again.

    You dont see the websites where? In the file system or in the webbrowser?

    Havye you tried using one of the perfect setup guides for setting up your server for ISPConfig?
  7. learning

    learning New Member

    That was quick

    Thanks for the Quick Response Till.

    I can't see the sites on my Web Browser. Right now its 3:15 am and I'm going on my third broken night. Would be nice to see the sites up b4 I go to bed though. Some info below,

    OS: Fresh Fedora Core v.5, Apache v.2, Webmin etc..

    This is the way I had it with the last server and it worked fine.

    Have two sites both of which respond to one the main nameservers/domain

    Name Servers (two IP addresses on one box): ns1.mymaindomain.us >> 69.xx.yyy.zza
    ns2.mymaindomain.us >> 69.xx.yyy.zzb

    A Record
    IP-Adresse Hostname
    69.xx.yyy.zza www
    69.xx.yyy.zza ns1.mymaindomain.us
    69.xx.yyy.zza ns2.mymaindomain.us
    69.xx.yyy.zza mymaindomain.us

    Hostname Target
    www.mymaindomain.us mymaindomain.us

    Mailserver Hostname
    www.mymaindomain.us www

    Site#1 (Site#2 is identical)
    A Record
    IP-Adresse Hostname
    69.xx.yyy.zza www.site1.com
    69.xx.yyy.zza site1.com
    69.xx.yyy.zza mail.site1.com

    Hostname Target

    Mailserver Hostname
    www.mymaindomain.us www

    Any Ideas???



    PS: I re-started Apache, no help
    Last edited: Nov 30, 2006
  8. falko

    falko Super Moderator ISPConfig Developer

    Can you post your real domain name here?
    What's the output of
    and what's in Vhosts_ispconfig.conf? Any errors in Apache's error log?
  9. learning

    learning New Member

    Three Questions

    I just started another thread named "Three Questions". I figured the answers may help. Also have another thread regarding link between BIND DNS and ISPConfig..


    Last edited: Dec 1, 2006
  10. learning

    learning New Member


    Manually create a "/etc/bind" directory.

    Fresh Fedora 5 does not create one so if you don't know you will crazy trying to figure this out. ISConfig uses this directory by Default with installation for DNS Zone configuration files.

    Would be nice if Newbies had more documentation on pre-installation..

    Hope this helps the next guy, Richard
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    This documentation exists and is linked on the ISPConfig documentation page ;)

    I guess you did not follow the perfect setup guide for fedora. Please have a look at the iSPConfig documenation page, use one of the perfect setup guides and you will have a fully working and configured system.

Share This Page