Vhosts_ispconfig.conf is blank

Discussion in 'Installation/Configuration' started by Drkoop81, Jan 20, 2009.

  1. Drkoop81

    Drkoop81 New Member

    I am having a problem with sites resolving to /var/www instead of their web1 web2 folders. Probably something simple I am not recognizing.

    Install went fine, I logged in, and I setup a first site like have done in the past but no go. It points to the root directory. I went looking for my Vhosts_ispconfig.conf file and it was blank. Is it supposed to be blank? The apache config file looks ok from what I know.

    Thanks for all the hard work on this. I really like ispconfig. It is awesome.

  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. Drkoop81

    Drkoop81 New Member

    Ok after making a backup of the Vhosts_ispconfig.conf and renaming the latest dated one I ran

    httpd -t
    it gave me an error

    httpd: bad user name ${APACHE_RUN_USER}
  4. Drkoop81

    Drkoop81 New Member

    based on this post I googled

    I changed the user and group in my /etc/apache2/apache2.conf to this below

    # These need to be set in /etc/apache2/envvars
    User www-data
    Group www-data
    Lets see if this works.
  5. Drkoop81

    Drkoop81 New Member

    So far it is not working. I changed the user and group www-data and restarted Apache. Not there yet.
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Then do the test again and see which error you are getting now.
  7. Drkoop81

    Drkoop81 New Member

    Yup I am on it..... Now I get an error

    Invalid command 'php_admin_flag', perhaps misspelled or defined by a module not included in the server configuration
  8. Drkoop81

    Drkoop81 New Member

    I am not sure what I did to disable the php module but as silly as that is I am now good to go.

    All I needed to do was

    'a2enmod php5' to enable the php module. Cheers to you Till for your patience and diligence.

    Koop over n' out :)

Share This Page