Vhosts_ispconfig.conf and multiple ServerAlias Problem

Discussion in 'General' started by JohnSmith, Nov 14, 2007.

  1. JohnSmith

    JohnSmith New Member

    If I put a couple (>=25) of ServerAliases to the Co-Domain-List the new builded Vhosts_ispconfig.conf has sometimes the Problem that there will be a linebreak within the ServerAlias-List. If so the Vhosts_ispconfig.conf will be not used and stored as Vhosts_ispconfig.conf_%date%-%time% and any further changes inside ISPConfig wont be updated to the system.
    Is there any known limitation to the ServerAlias-List or anything I can change in a config-File to get it work?
    The strange thing is that not always a newline after n Domains comes up but sometimes...?
    We have some customers wich have more than 100 Domains per Webspace - and therefor I need a "standard" I can follow (e.g. max 200 charackters in the ServerAlias-Line or max 20 Domains or something like that)
    Maybe someone has an Idea of changing some lines in a config file to get it working without limitation?

    You'll make me happy with any help ;-)
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    No, there is no limitation in lenght of domains or number of domains.

    If you have this problem, please have a look at the ispconfig db in the table isp_isp_domain, does the domain before the linrbreak appears have any special characcters or a linebreak that is saved in the database?
  3. JohnSmith

    JohnSmith New Member

    Dear Till,

    good idea, but there is not even a space in front of or behind the domain name.
    I've checked the domains forwards and after the linebreak.

    I've tried the following:
    Deleting the domains around the linebreak -> after deleting about six domains it works. I restore the deleted and the bug was back in place.
    So I delete the six domains again and put them manually back into the webspace. Now it works again - with the same number of co-domains...

    I think it was something like a hickup or a murphy error while put the co-domains in place the first time.

    Thanks for the help and for ispconfig ;-)

Share This Page