vhost problem: one subdomain doesn't respond

Discussion in 'Installation/Configuration' started by claudioimai, Jun 18, 2008.

  1. claudioimai

    claudioimai New Member

    Hello.

    My problem is quite weird.

    I have a domain set in a IP, with SSL and all.
    Some co-domains are set, and everything looks OK in the CP and the vhosts file.

    the VirtualHost for this domain has the lines:
    Code:
    <VirtualHost 78.47.195.35:80>
    ServerName ww2.corpoeforma.com.br:80
    ServerAdmin [email protected]
    DocumentRoot /var/www/web20/web
    ServerAlias www.suplementoalimentar.com.br suplementoalimentar.com.br www.corpoeforma.com.br www.fitforma.com.br fitforma.com.br corpoeforma.com.br
    DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
    
    As you can see, www.corpoeforma.com.br is in the list for the codomains, and it was the web domain before.

    The problem is that I can access this website with corpoeforma.com.br, www.suplementoalimentar.com.br, suplementoalimentar.com.br, etc. So, it looks that the DNS is OK and BIND9 is correctly setup, too.

    But www.corpoeforma.com.br doesn't work.
    The server seems to be blind to this subdomain, and sends the browser to the sharedip page.

    I've been checking all day for this error, but it seems to be something in my config.

    One thing I did to look for this error was downloading a SQL dump of the ispconfig database, and searched for the string "corpoeforma.com.br", in order to check if any of the strings had any hidden chars (spaces, etc), for previously mistaken configurations, but I couldn't find anything.

    Please, I have no other idea about it.
     
  2. claudioimai

    claudioimai New Member

    found solution

    Hi,

    I looked into the bind9 configuration file /var/lib/named/etc/bind/pri.domain.tld

    There, I found an entry as

    www a xxx.xxx.xxx.xxx, instead of the correct
    www a 78.47.195.35

    So, I manually changed the settings and now I'm just waiting for this change to spread.

    :confused:Question: what situation could make ispconfig to mismatch the IP like this?

    Thanks again,

    Claudio
     
  3. falko

    falko Super Moderator ISPConfig Developer

    Did you use the correct IP in the DNS Manager?
     
  4. claudioimai

    claudioimai New Member

    Hi, Falko

    As far as I can see, the co-domain doesn't have an option to select a different IP from the main domain. (unless we are talking about different things/settings- I assume that I am possibly wrong).

    I set 78.47.195.35 for this domain and all co-domains, as you can see in the attached image.

    Please point me where is the DNS manager you mentioned, since I don't recall it.
    Thanks again
     

    Attached Files:

  5. till

    till Super Moderator Staff Member ISPConfig Developer

    The IP for the DNS A-REcord can be set in the settings for the A-Record of the domain in the DNS-Manager. The screenshot you posted id from the website management form and not the dns manager.
     

Share This Page