vhost not working on ISPConfig 2.2.13

Discussion in 'Installation/Configuration' started by tannnk, Jun 22, 2007.

  1. tannnk

    tannnk New Member

    Hi, I have a problem setting a virtual host on apache2.
    I did a clean install on a Debian 4.0 using the perfect setup howto.
    My box has an internal IP address and is on DMZ on my gateway. I declared the external IP in ispconfig and selected that external address when I declared the new website.
    The problem is that when I go to www.xxx.com it redirects me to www.xxx.com/apache2-default/ and there is nothing I can do to get to my vhost.
    I have applied php 5.0.4 patch
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You must use your internal and not external IP in ISPConfig.

    This patch is deprected and unneeded but it does not harm.
  3. tannnk

    tannnk New Member

    I had the problem where Vhosts_ispconfig.conf was not being updated. After applying the patch it worked fine.

    I changed the IP address of my website from the external address to the internal and it worked fine.
    Last edited: Jun 22, 2007

Share This Page