vhost not being created in sites-enabled

Discussion in 'Installation/Configuration' started by ITI, Nov 3, 2017.

  1. ITI

    ITI New Member

    Centos 7, multi-server setup, ISPconfig 3.1.7p1

    When I create a new site, it is correctly added to "/var/www/..."
    However, the "newsite.vhost" file is not being created in "/etc/httpd/conf/sites-available" nor is the symlink being created in "/etc/httpd/conf/sites-enabled".
    I had some messed up file permissions on the mater-server a while back and wondering if this is the cause?
    Update:
    I just discovered that when a site is deactivated the symlink in sites enabled is not being removed.
    Note: this is on a separate webserver and it did work initially.
    Any suggestions please.

    Update: ISPconfig is writing to wrong path. See new info below.
     
    Last edited: Nov 3, 2017
  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. ITI

    ITI New Member

  4. ITI

    ITI New Member

    I've been looking through the debug log and noticed the system is writing to the wrong paths.
    Debug log says:
    Code:
    03.11.2017-13:15 - DEBUG - Writing the vhost file: /etc/apache2/sites-available/newsite.ca.vhost
    03.11.2017-13:15 - DEBUG - Creating symlink: /etc/apache2/sites-enabled/100-newsite.ca.vhost->/etc/apache2/sites-available/newsite.ca.vhost
    The correct path should be: /etc/httpd/conf/sites-enabled and /etc/httpd/conf/sites-avaialbe
    Where/how do I correct this path error?
    Thanks
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    System > Server config
     
  6. ITI

    ITI New Member

    Thank you very much ...
    Do you happen to know what caused this path to be changed?
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    No, have not seen that problem yet.
     

Share This Page