vhost missing SSL section when adding Letsencrypt SSL Certificate

Discussion in 'ISPConfig 3 Priority Support' started by edworcs, Oct 24, 2017.

  1. edworcs

    edworcs New Member HowtoForge Supporter

    I'm absolutely sure I'm not ticking a box in the right place here...

    When I add a new domain to the server and tick the SSL and Letsencrypt boxes the certificates are created in /etc/letsencrypt but the vhost.conf file for the domain name is not updated with a <VirtualHost *:443> section. No section with a 443 port is added.

    Letsencrypt works for a domain where I specify an IP address i.e. the IP address is not shared and specific to a site. It does not work when using a shared IP address. I have looked at the SNI capability of Apache and it looks like it is enabled (I get the "right" warning - see below).

    The Debug log shows the certificate being issued correctly and says that ISPConfig is "Writing the vhost file". No clear errors in the log.

    I have NameVirtualHost *:443 in /etc/httpd/conf/httpd.conf and <VirtualHost _default_:443> in /etc/httpd/conf.d/ssl.conf

    My problem seems to have been described in this Topic (but the solution wasn't provided):
    https://www.howtoforge.com/communit...host-conf-file-when-using-lets-encrypt.73919/

    Can anyone advise what I might be missing?

    Thanks,

    Ed

    My Setup
    Centos 6.9
    ISPConfig 31.17p1
    Apache 2.2.15
    SNI Support should be on (get the warning [warn] Init: Name-based SSL virtual hosts only work for clients with TLS server name indication support (RFC 4366)
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The SSL vhost gets added only when the SSL cert was created properly and when apache is able to start with that configuration. Please post the debug log that you get when you run server.sh after you enabled LE for a website.
     

Share This Page