vhost behaves "strange"

Discussion in 'Installation/Configuration' started by ZeroEnna, Jan 21, 2013.

  1. ZeroEnna

    ZeroEnna Member

    Hey everyone,

    I just found something weird.
    I have a Multiserver running under Debian Squeeze, however, both are set up with different tutorials (there are about 15 months between each server).

    I created a subdomain "files.example.com" on the master as a regular domain, and it works perfectly.
    Now I created a subdomain "files.example.de" on the slave. It is created, the vhost file is created as usual, but it seems to be ineffective.

    Instead of the domain I created, all requests are related to the site that is first in alphabetical order, "constory.de".

    What's wrong here? All settings are exactly the same as on the master.

    What information do you need to help me?

    Regards


    Zero


    EDIT: normal websites, like "example.de" are working fine on the slave, only subdomains are making trouble
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Do you use the correct IP address in the vhost? Does the subdomain point to the correct IP?
     
  3. ZeroEnna

    ZeroEnna Member

    yes to both, I just checked it.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    I had a similar issue some time back were apache did not picked up new changes caused by a hanging apache process. Please try to stop apache and then check with:

    ps -aux | grep apache
    ps -aux | grep http

    that no apache processes are running anymore. If you still find apache processes, then kill them or restart the server.

    If thats ok, then check if the symlink in /etc/apache2/sites-enabled/ points to the correct vhost file in /etc/apache2/sites-available/

    A third thing is the dns, check that the dns record for files.example.com really points to the correct IP address. And dont mix * and IP addresses in the website settings in ispconfig on the same server. If you mix them, all * records will get ignored.
     

Share This Page