vhost and sym links not syncing up

Discussion in 'General' started by dkdzn, Mar 8, 2011.

  1. dkdzn

    dkdzn New Member

    Hello,

    ISPConfig has worked flawlessly so far. But, now there is a problem I don't understand.

    When I set up a new subdomain (I know, you have to create a whole new site using ISPConfig's website tab... not the subdomain tab)... it creates the subdomain (sub.domain.com) and registers it... but the symlinks and what it says in the vhosts files in /etc/apache2/sites-enabled and sites-available are different.

    If I use and FTP program to follow the symlink it'll go to /var/www/clients/client_1/web_33.

    But in the vhost files for that new subdomain (sub.domain.com.vhost) the directory says /web_35.

    Am I doing something wrong? Or is there a problem with ISPConfig.

    TIA,
    ~dkdzn
     
  2. till

    till Super Moderator

    Did you create a subdomain or a new website? Subdomians are aliases for websites and dont have a own vhost file.
     
  3. dkdzn

    dkdzn New Member

    No. Like I said... I created a new website. I did not use the subdomain section of ISPconfig even though it's "sub.domain.com". You were very specific about that last time and I've noticed it a common issue.

    This time I definitely used the main website section.

    ~dkdzn
     
  4. till

    till Super Moderator

    Which ISPConfig version do you use? Did you created a website sub.domain.com.vhost before or did you renamed the website (web33) from sub.domain.com.vhost to another domain before you created the new website?
     
  5. dkdzn

    dkdzn New Member

    I'm using ISPConfig Version: 3.0.3.1.

    I don't understand what you're asking me.

    I did notice that when I delete the old website using ISPConfig and then recreate it with the same address (sub.domain.com) it creates the new directory with a new number (web_36) and creates new vhost files that are right (web_36) but the symlink is still going to a wrong directory (web_32).

    ~dkdzn
     
  6. dkdzn

    dkdzn New Member

    No... this is the first time I every created the website with that subdomain. (sub.domain.com).

    The top-level domain (domain.com) has existed for a long while. I've also successfully created dozens of subdomains for it in the past (with your help before in the past before).

    ~dkdzn
     
  7. till

    till Super Moderator

    So this symlink existed before you created the new website?
     
  8. dkdzn

    dkdzn New Member

    I don't know. It may have... I've created and deleted domains and subdomains multiple times throughout the months. It's not been a problem.

    As to whether or not web_32 existed (or web_33... which is where the old but also wrong symlink went) ... I don't know.

    The reason I'm using ISPConfig is so that I don't have to worry about that stuff and to make my life easier.

    ~dkdzn
     
  9. till

    till Super Moderator

    Ok. But if we want to find the reason for the problem, I need to have to ask such questions. There were problems with not completely deleted symlinks in older ispconfig releases. Please update to ispconfig 3.0.3.2, then remove that symlink on the shell and edit a setting in the website (e.g. change the quota or enable a checkbox) and click on save, so that ispconfig recreates the symlink.
     
  10. dkdzn

    dkdzn New Member

    I understand... that's why I love ISPConfig... because it's still in active development and not abandoned. :)

    Do I just download the new version and upload? How to I upgrade?

    ~dkdzn
     
  11. till

    till Super Moderator

    No need to download it manually. Login on the shell as root and execute the command:

    ispconfig_update.sh
     
  12. dkdzn

    dkdzn New Member

    I did as you said... upgraded to 3.0.3.2 (checked version to confirm). I deleted both symlinks (in /var/www and /var/www/clients/client_1). And it didn't work. Now the vhost says "web_36" and the two new symlinks are "web_32" and "web_33" respectively.

    ~dkdzn
     
  13. till

    till Super Moderator

    Hmm, thats strange. Please post the output of:

    ls -la /var/www/clients/client_1/
     
  14. dkdzn

    dkdzn New Member

    Here you go. I replaced the actual domains and subdomains with sub1, sub2, etc... and domain1, domain2, etc.


    root@marty:/etc/apache2/sites-enabled# ls -la /var/www/clients/client_1/
    total 52
    drwxr-xr-x 13 root root 4096 Mar 8 20:57 .
    drwxr-xr-x 3 root root 4096 Jan 2 09:25 ..
    lrwxrwxrwx 1 root root 33 Jan 7 21:32 domain1.org -> /var/www/client s/client_1/web_31/
    lrwxrwxrwx 1 root root 33 Jan 7 21:30 domain2.com -> /var/www/cl ients/client_1/web_30/
    lrwxrwxrwx 1 root root 33 Jan 4 15:17 sub1.domain3.com -> /var/www/clie nts/client_1/web_14/
    lrwxrwxrwx 1 root root 33 Jan 3 15:19 sub2.domain3.com -> /var/www/clients/ client_1/web_13/
    lrwxrwxrwx 1 root root 32 Jan 2 09:34 domain4.com -> /var/www/ clients/client_1/web_6/
    lrwxrwxrwx 1 root root 32 Jan 2 09:25 domain3.com -> /var/www/clients/clie nt_1/web_5/
    lrwxrwxrwx 1 root root 33 Jan 4 22:58 sub3.domain3.com -> /var/www/client s/client_1/web_23/
    lrwxrwxrwx 1 root root 33 Mar 8 20:57 sub4.domain3.com -> /var/www/clients/ client_1/web_36/
    lrwxrwxrwx 1 root root 32 Jan 2 09:36 sub5.domain3.com -> /var/www/clien ts/client_1/web_7/
    lrwxrwxrwx 1 root root 33 Jan 5 19:38 sub6.domain3.com -> /var/www/client s/client_1/web_28/
    drwxr-x--x 6 web13 client1 4096 Jan 4 20:22 web_13
    drwxr-x--x 6 web14 client1 4096 Jan 4 21:28 web_14
    drwxr-x--x 6 web23 client1 4096 Jan 4 22:58 web_23
    drwxr-x--x 6 web28 client1 4096 Jan 5 02:10 web_24
    drwxr-x--x 6 web28 client1 4096 Jan 5 18:30 web_28
    drwxr-x--x 6 web30 client1 4096 Jan 7 21:30 web_30
    drwxr-x--x 6 web31 client1 4096 Jan 7 21:32 web_31
    drwxr-x--x 6 web36 client1 4096 Mar 8 20:28 web_36
    drwxr-x--x 6 web5 client1 4096 Feb 19 18:48 web_5
    drwxr-x--x 6 web6 client1 4096 Mar 8 00:30 web_6
    drwxr-x--x 6 web7 client1 4096 Mar 8 00:30 web_7
     
  15. till

    till Super Moderator

    The symlink sub4.domain3.com points to /var/www/clients/ client_1/web_36/. I dont see a symlink to web32 or web33 there and there are also no directories web32 or web33, so that looks ok for me.
     
  16. dkdzn

    dkdzn New Member

  17. dkdzn

    dkdzn New Member

    Is there any other further info you can provide on this issue?
     
  18. dkdzn

    dkdzn New Member

    I recreated the sites using ISPConfig and... for whatever reason... the symlinks are now correct in FileZilla. However, the sites are still not working and I still get 404s.

    Please advise.
     
  19. dkdzn

    dkdzn New Member

    Right now, it seems everything is correct but the site is still 404. Are you part of the ISPConfig development team? And, if so, do you have an email I can send you private information?
     

Share This Page