vhcs2 auto responder not working

Discussion in 'Installation/Configuration' started by Reptile, Sep 4, 2007.

  1. Reptile

    Reptile New Member

    Seems the official forums are closed and I don't know where else to turn so i have come here :D

    I am trying to get the auto responder working on the email but I get a message returned to me saying this

    Code:
    : Command died with status 255:
        "/var/www/vhcs2/engine/messager/vhcs2-arpl-msgr". Command output: If
        specified by -literal_key, then the key length must be equal to the chosen
        cipher's key length of 56 bytes at
        /var/www/vhcs2/engine/messager/vhcs2-arpl-msgr line 1410
    
    I checked the master.cf file to see if there were any parameters passed to vhcs2-arpl-msgr and none where.

    It seems that the script has a problem decrypting some key and cannot retreive the auto response message from the database, maybe?
     
  2. chuckl

    chuckl New Member

    What version are you using? There were some changes to where the Postfix keys were kept round version 2.4.7
     
  3. Reptile

    Reptile New Member

    2.4.7.1 is the current version. From memory it was a claen install and it says there are no upgrades in the control panel.
     
  4. chuckl

    chuckl New Member

    Ok, then does the /var/www/vhcs2/engine/messager folder contain
    vhcs2-db-keys.pl?
    From the error, it sounds tome like it is missing a keyfile or key access file.

    My evaluation version is the VmWare image with 2.4.7, haven't used it in a year or so, but I can fire it up and check?
     
  5. Reptile

    Reptile New Member

    yes it does. The contents have a file with 32 characters in db_pass_key.
     
  6. chuckl

    chuckl New Member

    Right found the VM and reloaded it, that looks like it's in the db password decrypt routine.
    Can you check the owner and group on the db_pass_key file? Should be vmail and mail.
    Can also check the /etc/postfix main.cf for a line like

    vhcs2-arpl_destination_recipient_limit = 1

    and try adding that if it's not there.
     
  7. Reptile

    Reptile New Member

    yeah that line is there and the permissions are correct. I tried applying the so called fix i found in the vhcs wiki but it's actaully for a different error message. SO still no luck.
     
  8. chuckl

    chuckl New Member

    No recent changes to passwords etc? only other possibility is the conf file, but it's dying on the password decrypt, which suggests either a bad password, wrong cipher, changed key or similar.

    I discovered that the VMWare image is actually 2.4.7.1, on Debian Sarge, so if you can give me an example of exactly what you were trying, I can test it out on a 'clean' system.
     
  9. Reptile

    Reptile New Member

    Nope nothing since I installed the system from clean.

    I basically went into the control panel, added an email address and turned on the auto responder. I emailed myself as a test and get that error message instead.

    the error message seems to be the key length. maybe i can safely regenerate a new one? The only problem is it is running a company's email system and i cant sod it up.
     
  10. chuckl

    chuckl New Member

    OK, create hosted domain, add a user/email address, turn on autoresponder and light blue paper.
    Let me give it a try and see what blows up. I've got what is essentially a clean install, so not corporate repercussions involved.
     
  11. Reptile

    Reptile New Member

    cheers, i appreciate the effort you are putting in for me.
     
  12. chuckl

    chuckl New Member

    Ok, try replacing the code round the error message line with this

    my $cipher = Crypt:: CBC - > new (
    {
    `keys' => $main:: db_pass_key,
    `keysize' => 32,
    `cipher' => `Blowfish',
    `iv' => $main:: db_pass_iv,
    `regenerate_key' => 0,
    `padding' =>' space',
    `prepend_iv' => 0
    }
    );

    Essentially add the keysize 32 value, and see if that helps

    Rgds,
     
  13. Reptile

    Reptile New Member

    I added that line of code but now I get nothing instead of an error email. So there is no automated response. There seems to be nothing in the mail log either. :(
     
  14. chuckl

    chuckl New Member

    Bad description by me, you have to insert that in every instance of Crypt::CBC in the file, there are at least 2 in vhcs2-arpl-msgr.pl, and more in /var/www/vhcs2/engine/vhcs2-common-code.pl.

    While you are in arpl-mgr, check near the end, round line 1780 for this code

    if($auto_message ne '_no_') {

    if($name) { $mail_to = "\"".$name."\" "."<".$to_ma->address.">"; }


    and add this

    next if $mail_to =~ /vhcs2-arpl/;

    immediately after.

    Couple more things I changed, I'll post them in a moment. Place to check for problems is the mail log - in Debian - /var/log/mail.log, or mail.err, or mail.warn
     
  15. chuckl

    chuckl New Member

    Check in /var/www/vhcs2/gui/tools/webmail/inc/inc.php for the lines

    Header (” You expire: Wed, 11 Nov 1998 11:11: 11 GMT \ r \ n”.
    “Break-Control: \ n not-breaks \ r”.
    “Break-Control: must-revalidate”);

    and remove any '\r' and '\n' that you find there.

    I also ran through all of the stuff here for vhcs2-arpl-msgr.pl under 'autoresponder not working',

    http://vhcs.puuhis.net/wiki/index.php/Frequently_Asked_Questions

    and also moved the

    vhcs2-arpl_destination_recipient_limit = 1

    line in main.cf to just under

    local_recipient_maps = unix:passwd.byname $alias_database

    in /etc/postfix/main.cf.

    Shouldn't make any difference, but when you're waving dead chickens at the problem, you just do it.

    I also picked up a comment that vhcs2-arpl-msgr needs a folder for it's log files in /var/log/vhcs2 called vhcs2-arpl-msgr.
    i.e. create folder
    /var/log/vhcs2/vhcs2-arpl-msgr and set owner to vmail, group mail.

    Nothing ever appears in there, but hey...
     
  16. Reptile

    Reptile New Member

    nah, sorry to say I still receive email ok in the account but no auto respond message is being delivered :(


    Sep 5 13:21:56 viking postfix/pipe[28384]: B9BC419C674: to=<a@vhcs2-arpl.rep.co.uk>, orig_to=<a@rep.co.uk>, relay=vhcs2-arpl, delay=1, status=sent (vhcs2-arpl.rep.co.uk)

    Sep 5 13:21:56 viking courierpop3login: Connection, ip=[::ffff:86.27.74.225]
    Sep 5 13:21:56 viking courierpop3login: LOGIN: DEBUG: ip=[::ffff:86.27.74.225], command=CAPA

    Sep 5 13:21:56 viking postfix/pipe[28385]: B9BC419C674: to=<a@vhcs2-arpl.rep.co.uk>, relay=vhcs2-arpl, delay=1, status=sent (vhcs2-arpl.rep.co.uk)

    Sep 5 13:21:56 viking postfix/qmgr[28367]: B9BC419C674: removed
     
  17. chuckl

    chuckl New Member

    But no error messages in the logs etc anymore?

    Have a look at the transport and aliases files in /etc/postfix/vhcs2 the aliases file should show an additional entry for the autoresponder for the user withit enabled, and the transport file should show an autoresponder transport defined, matching the definition in aliases.
    And to check the obvious, I assume you've put something in the autoresponder message?
    I'll post the log entries from the VM machine in a mo, for comparison. The other thought is that I'm using the webmail interface.
     
  18. Reptile

    Reptile New Member

    There are no error messages at all.

    I have put a message in the auto responder and it appears that the alias and transport files have the autorespond code in them on the correct email.

    I am using pop/smtp but that shouldn't matter because it's the person who sends the email that should receive the autoresponder.
     
  19. chuckl

    chuckl New Member

    OK, the complete transaction on the VM mail log looks like this:
    (Only user admin has an autoresponder enabled, hence mail from user test to admin).

    Sep 5 13:04:07 victor postfix/smtpd[1718]: 0104019C026: client=victor.theredmans.me.uk[127.0.0.1]
    Sep 5 13:04:08 victor postfix/cleanup[1710]: 0104019C026: message-id=<963bc0286904712382a7cd3b8330683f@192.168.0.145>
    Sep 5 13:04:08 victor postfix/qmgr[1190]: 0104019C026: from=<test@vhcs.theredmans.me.uk>, size=12958, nrcpt=3 (queue active)
    Sep 5 13:04:08 victor postfix/smtpd[1718]: disconnect from victor.theredmans.me.uk[127.0.0.1]
    Sep 5 13:04:08 victor postfix/smtp[1711]: 3F35919C011: to=<admin@vhcs.theredmans.me.uk>, relay=127.0.0.1[127.0.0.1], delay=2, status=sent (250 2.6.0 Ok, id=00909-01, from MTA: 250 Ok: queued as 0104019C026)
    Sep 5 13:04:08 victor postfix/smtp[1711]: 3F35919C011: to=<admin@vhcs2-arpl.vhcs.theredmans.me.uk>, orig_to=<admin@vhcs.theredmans.me.uk>, relay=127.0.0.1[127.0.0.1], delay=2, status=sent (250 2.6.0 Ok, id=00909-01, from MTA: 250 Ok: queued as 0104019C026)
    Sep 5 13:04:08 victor postfix/qmgr[1190]: 3F35919C011: removed
    Sep 5 13:04:08 victor postfix/virtual[1719]: 0104019C026: to=<admin@vhcs.theredmans.me.uk>, relay=virtual, delay=0, status=sent (delivered to maildir)
    Sep 5 13:04:10 victor postfix/pipe[1722]: 0104019C026: to=<admin@vhcs2-arpl.vhcs.theredmans.me.uk>, relay=vhcs2-arpl, delay=2, status=sent (vhcs2-arpl.vhcs.theredmans.me.uk)
    Sep 5 13:04:10 victor postfix/pickup[1575]: 5E58B19C011: uid=1001 from=<vmail>
    Sep 5 13:04:10 victor postfix/cleanup[1710]: 5E58B19C011: message-id=<20070905120410.5E58B19C011@victor.theredmans.me.uk>
    Sep 5 13:04:10 victor postfix/qmgr[1190]: 5E58B19C011: from=<vmail@server.local>, size=13974, nrcpt=1 (queue active)
    Sep 5 13:04:10 victor postfix/pipe[1720]: 0104019C026: to=<admin@vhcs2-arpl.vhcs.theredmans.me.uk>, orig_to=<admin@vhcs.theredmans.me.uk>, relay=vhcs2-arpl, delay=2, status=sent (vhcs2-arpl.vhcs.theredmans.me.uk)
    Sep 5 13:04:10 victor postfix/qmgr[1190]: 0104019C026: removed
    Sep 5 13:04:11 victor postfix/smtpd[1718]: connect from victor.theredmans.me.uk[127.0.0.1]
    Sep 5 13:04:11 victor postfix/smtpd[1718]: 312AA19C026: client=victor.theredmans.me.uk[127.0.0.1]
    Sep 5 13:04:11 victor postfix/cleanup[1710]: 312AA19C026: message-id=<20070905120410.5E58B19C011@victor.theredmans.me.uk>
    Sep 5 13:04:11 victor postfix/qmgr[1190]: 312AA19C026: from=<vmail@server.local>, size=14478, nrcpt=1 (queue active)
    Sep 5 13:04:11 victor postfix/virtual[1719]: 312AA19C026: to=<test@vhcs.theredmans.me.uk>, relay=virtual, delay=0, status=sent (delivered to maildir)
    Sep 5 13:04:11 victor postfix/qmgr[1190]: 312AA19C026: removed
    Sep 5 13:04:11 victor postfix/smtpd[1718]: disconnect from victor.theredmans.me.uk[127.0.0.1]
    Sep 5 13:04:11 victor postfix/smtp[1711]: 5E58B19C011: to=<test@vhcs.theredmans.me.uk>, relay=127.0.0.1[127.0.0.1], delay=1, status=sent (250 2.6.0 Ok, id=00910-01, from MTA: 250 Ok: queued as 312AA19C026)
    Sep 5 13:04:11 victor postfix/qmgr[1190]: 5E58B19C011: removed
     
  20. chuckl

    chuckl New Member

    And with a little imagination, the message is being piped to the autoresponder, and on to admin, and an autoresponder response is being piped back out to user test.

    Might be worthwhile running portmap /etc/postfix/vhcs2/aliases, and ditto for transport, just to recreate the db files.
     

Share This Page