Very begining steps after installation

Discussion in 'Installation/Configuration' started by carlosopenges, Jul 16, 2017.

  1. carlosopenges

    carlosopenges New Member

    Hi all,
    I have a domain, example.com, with registered nameserver (ns1.example.com and ns2.example.com) pointing with glue records to the IP 111.222.333.444.
    I have a VPS with this IP as network address. I have installed ISPConfig 3.1dev as mentioned in: The Perfect Server CentOS 7.3 with Apache, Postfix, Dovecot, Pure-FTPD, BIND and ISPConfig 3.1
    This server is named server1.example.com and has to be the SOA of the domain.
    I have imported a previously working zone for this domain:
    --------------------------------------------------------------------------------------------------------------------
    $ttl 1800
    @ IN SOA example.com. hostmaster.example.com$
    2017071502 ;Serial, todays date + todays serial #
    1H ;Refresh
    1H ;Retry
    1W ;Expire
    1H ;Minimum
    )
    ;Nameservers
    IN NS ns1.example.com.
    IN NS ns2.example.com.

    ;Resolve Nameserver IPs
    ns1 IN A 111.222.333.44
    ns2 IN A 111.222.333.44

    ;Define hosts resolutions
    @ IN A 111.222.333.44 ;ns1
    @ IN A 111.222.333.44 ;ns2
    mail IN A 111.222.333.44
    ftp IN A 111.222.333.44

    ;MX records
    example.com. IN MX 10 mail.example.com.

    ;CNAMEs
    www IN CNAME @

    ;TXT Records
    example.com. IN TXT "v=spf1 ip4:111.222.333.444 include:_spf.google$
    -----------------------------------------------------------------------------------------------------------------------------------
    This VPS it will have only this domain.

    I have bought the ISPConfig Manual with the hope that I should find the first steps all ISPConfig installations needs but I couldn't find it.

    If I try to test this example.com dns in places like leafdns.com I get:

    ns1.example.com. 111.222.333.444 Glue:Yes TTL:172800
    FAIL: Nameserver is not authoritative for example.com.
    ns2.example.com. 111.222.333.444 Glue:Yes TTL:172800
    FAIL: Nameserver is not authoritative for example.com.
    What I have to do?.
    Thanks.
     
  2. carlosopenges

    carlosopenges New Member

    Nobody knows?
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    The system is ready to be used when you followed the perfect server guides. So there are no further steps that need to be done on all systems. Instructions on how to do individual tasks like how to add a dns record or a website can be found in the manual.

    If your dns is not working, then take a look at the folder where the BIND config files are stored to see if your zone file has no .err ending. If it has a .err ending, then bind rejected it. you can find the detailed error in the system.log then or by using the named-checkzone command to test the file.
     
  4. carlosopenges

    carlosopenges New Member

    Thanks Till. I was lost and I solved it with your suggestions.

    For the future readers:
    - When you create a DNS with the wizard the A record for the ns1 and ns2 nameservers are not setted automatically. You have to point the ns host to your ip adding a new A record per each ns you have. I have not been able to find this on the manual.
    - I haven't been able to find the system.log file, that's because in CentOs has a different name, /var/log/messages.
    - The named-checkzone only has worked when the zone was well configured.

    I have it running so thanks again.
     

Share This Page