variable conf unknown

Discussion in 'Installation/Configuration' started by germinator, Feb 4, 2011.

  1. germinator

    germinator New Member

    Hello Community,
    today I tried to update my Ispconfig 3 software via the webinterface. After a couple of minutes Ispconfig was down ... meaning the webinterface was not reachable, however, all services are started. Then I tried a manual update using the "" which is where I got the error

    Notice: Undefined variable: conf in /tmp/ispconfig3_install/install/update.php on line 76
    the setup has been running for 2 months smoothly and I looked into the update.php and saw that in the beginning the variable conf gets the hostname info and my hostname and hostname -f have the same output if thats important ... any thoughts how to solve this ? I have read a thread saying that uninstall.php and then running install.php might help, but does that delete the sites that were created by ispconfig? Because that would give me a ton of work, however, if there is no other way its possible too.



    I have noticed my ispconfig.vhost and ispconfig.conf in /etc/apache2/sites-available are empty .. maybe thats the problem? If it is, what do I have to put in there to make it work?
    Last edited: Feb 5, 2011
  2. atran

    atran New Member

    i have the same problem and also don't know how to resolve this...

    i tried uninstall.php but it hangs!

    also /usr/local/ispconfig/server/lib/ is empty?

    is there a way to do a forced reinstall/update?
  3. till

    till Super Moderator Staff Member ISPConfig Developer


    Have you created a backup before you updated?

    Do not run uninstall.php, it will remove your setup and all config.

    I recommend to install updates always on the shell by running the "" script as described in the release notes.

    To fix your setup, please take a look into the file /usr/local/ispconfig/server/lib/ and check if its empty.


    Thats not good as the uninstall script is made to clean a system and permamnently remove ispconfig, so everything configured in ispconfig gets lost.

    That depends in which step the unistall hanged. Most likely all information that is nescessary to do a upgarde might be lost due to the unstall run. Do you have a backup?
  4. atran

    atran New Member

    i fixed it!
    First i quickly install a new installation (doesn't had backups yet).
    Then copied over the "/usr/local/ispconfig/server/lib/" to the first server.
    Also changed the mysql password in "/usr/local/ispconfig/server/lib/" to be the same as in "/usr/local/ispconfig/interface/lib/" (which wasn't empty).
    then i download the latest stable version and unpacked it to /tmp.
    Then run "php -q update.php" (from folder /tmp/ispconfig3_install/install/).

    btw. the uninstall hangs right after the ispconfig logo art.

Share This Page