v2.2.22; New site user; The selected diskspace exceeds site's limits.

Discussion in 'General' started by Fredrik75, Apr 10, 2008.

  1. Fredrik75

    Fredrik75 New Member

    Hi!

    Just upgraded our ispconfig to 2.2.22, and now a new error occurs.
    When adding a new user to a site with -1 in "Webspace MB" this error appears:
    "The selected diskspace exceeds site's limits."

    It works ok if I i write an number there instead (ie. 200).

    Suggestions?

    /Fredrik

    Ps. Thanks for a great panel!!
     
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    What is the space limit of the site? The limit of the user must be smaller then the limit of the site. You can not set the user limit to -1 when you have set a quota limit of the site.

    This was possible in prior versions due to a bug and this is fixed now in 2.2.22.
     
  3. Fredrik75

    Fredrik75 New Member

    Ah, I was in the impression of that if the user had -1 it was set to the same as the site-quota. This is the administrator of the site...
     
  4. AlArenal

    AlArenal New Member

    Hm.. the default user webspace limit of '-1' has always worked, but with the latest version it doesn't anymore. Users with access to ISPC now start bugging me about why they get this message when they change their account details - of course because '-1' has always been the default setting... :mad:
     
  5. tal56

    tal56 New Member

    Till,

    This seems to be coming up a lot as users upgrade to the newest version. I understand that if you set all the users to the same limit as the site, then that space is shared up to the site limit, but to me it's just easier to be able to set the user limit as -1 and have the same results.

    If I have to set the user limit as the site limit, I have to go and look up the site limit each time I'm adding a user, and each site has differnt limits, at least on my system.

    Also if I change a site's limit in the future to give them more space, now I have to go and change EVERY user's limit again to match the site limit.

    To me, if they are just left -1 and all spit the site limit, that just seems much easier to maintain. If someone wants to set a hard limit for a specific user, then that's when we should need to go in and change it.
     
  6. xrat

    xrat Member

    As tal56 above wrote, what are we supposed to do now with existing entries? You say, -1 is not valid anymore, right? What should we do with the many existing users who have this value set?
     
  7. minimalist

    minimalist New Member

    Having the same problem here!
    We found it normal for a user to set the limit to "-1" and be limited by the quota of the website...

    Any suggestions?
     
  8. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    I will see if we can make this configurable in the next version, so that you can switch between old and new behaviour in the config.inc.php file.
     
  9. mmiyamoto

    mmiyamoto ISPConfig Developer ISPConfig Developer

    Hello,
    Also for me the same problem, I am using that user has no limitations on space, I am using version 2.2.22, I also installed the patch for 2.2.23, but when I make any type of operation I find the following message. The selected diskspace exceeds site's limits.


    Tnx


    Fino
     
  10. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Just set the limit of the user to the same limit then the site.
     
  11. mmiyamoto

    mmiyamoto ISPConfig Developer ISPConfig Developer

    My user have all setting with lo limit -1 . With the version 2.2.21 don't have any problem.
     
  12. tal56

    tal56 New Member

    BIG Thanks Till,

    Would love to see this feature back in the next version.
     
  13. xrat

    xrat Member

    Thanks! Looking forward to it!

    To the fellow users/admins/readers: I kept the -1 settings and until now I see no harm. The quota limits (checked on the shell) are unchanged.

    Apparently, since the -1 causes an error you might want to manually initiate the rewriting of configuration files with
    Code:
    touch /home/admispconfig/ispconfig/.run
     
    Last edited: Apr 20, 2008
  14. wrapier

    wrapier New Member

    Quotalimit has to be flexible

    This is neither applicable nor efficient if i have a Site witch gets a higher Quota after some time.

    It would be so great if there is an option to get a flexible user limit!
    That would save a lot of time, in the case.

    regards and thanks for this nice piece of software.
    ISPConfig rocks for me :)
     
  15. AlArenal

    AlArenal New Member

    Additional bug:

    A customer of ours has the web quota set to 1000 MB, the ftp/mail user accounts all have default value -1. So he experiences the quota error every time he wants to change mail forwarding, for example.

    BUT:
    ISP takes the user changes although displaying the error message, but does NOT rewrite the user's .forward file!

    Haven't tried this myself by now and haven't checked it in 2.2.23. Just received a call today and encountered this problem.
     
  16. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    The .forward file is not related to quota and has not to be rwritten for quota changes.
     

Share This Page