V Users & Domains w/ Postfix, Courier, etc. w/ mailstore on Win-SMB Share(NAS) HELP!

Discussion in 'HOWTO-Related Questions' started by AlyK, Jun 18, 2009.

  1. AlyK

    AlyK New Member

    Postfix & Courier w/ mailstore on SMB Share(NAS) fetch failure...

    Hey all. I have successfully followed the howto for Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail (CentOS 5.3 x86_64) (but for x86) and I have implemented this system successfully a few times. However I seem to have hit a issue. I have a situation where i have to place the mailstore on a windows NAS. I can sucessfully mounted the share with the correct gid/uid and i can get postfix to delivery mail to it properly however i can't seem to get courier to fetch the mail / display mail in any app (squirrel for example).

    It shows that there is in new messages eg: [Inbox (2)] but isn't able to display the mail itself.

    I have also attempted to maually telnet into the imap server and fetch mail and recieved the following error:
    a fetch 2 body[text]
    * 2 FETCH ()
    * NO Cannot open message 2
    a OK FETCH completed.
    a fetch 1 body[text]
    * 1 FETCH ()
    * NO Cannot open message 1
    a OK FETCH completed.

    After trying manually or via an mail app i see the following errors in the /var/log/maillog:
    Jun 18 09:33:48 mail01 imapd: rename(./new/1245268538.V17I22ed9bM285388.mail01.company.net,S=1034,./cur/1245268538.V17I22ed9bM285388.mail01.company.net,S=1034:2,)
    failed: No such file or directory

    // /MailStoreAmun cifs username=net/linuxmail,password=Password1,uid=vmail,gid=vmail,auto,iocharset=utf8,file_mode=0700,dir_mode=0700 0 0
    I have also tried modes 0777 just to test with no change in results.

    authmysql(key parts for this issue):
    MYSQL_HOME_FIELD "/MailStoreAmun"

    After some Googling i have read that it might be use to the MYSQL_MAILDIR_FIELD string, however i don't feel this is the exact issue as all permissions and and paths are all relative to the file system and i can't see how it would be affected just because this is a smb share.
    Any help would be greatly appreciated. Thanks to all in advance.
    Last edited: Jun 18, 2009
  2. falko

    falko Super Moderator ISPConfig Developer

    I guess this is a permissions problem. Maybe it has something to do with dir_mode=0700 in your fstab?
  3. Flash

    Flash New Member

    I recently set up a vmail server myself also with courier. What I noticed is that Courier expects exactly the right user/group else it will not work.

    so if you have user alyk (uid 1000?) with group users (uid 100?) set up in your database, make sure its like that on the directory aswell. a quick chown -R should do the trick.
  4. AlyK

    AlyK New Member

    No go :(

    Hey all,
    I have made a few adjustments as per your guys posts and i am still having the same issue. I changed the file, dir mode to 0777 just for test and that didn't change anything i also removed those two entries and it also didn't change anything. I have confirmed the UID and GID as per the HOWTO is set to 5000 across the mount, postfix, and courier.

    I continue to get the same error. Postfix can deliver without issues courier can see mail is in the bin, but it just can't show it. I am stumped any idea's??

Share This Page