UTF-8 conversion

Discussion in 'Installation/Configuration' started by rvarkevisser, Apr 20, 2007.

  1. rvarkevisser

    rvarkevisser New Member

    Hi there,

    I have a problem and I can not figure out how to solve this. I've been at it for the last three weeks and still don't have a solution. Here's the problem

    http://www.la-capirinha.nl/test.htm

    The Euro, apostrophe etc. are all shown as squares. I use apache2.0.54 with ISPConfig. The OS is Debian Etch Stable. I installed every Charset I could find and tried every locale setting. I now use [email protected]

    I have another server which runs Debian Sarge stable and here every thing is fine. The problem is that on the Debian Edge server, I have around 130 customer websites running. So I really need a solution!
    I tried to set the default charset to UTF-8 in apache2.conf. I tried defaultcharset off. I tried everything. Maybe UTF-8 isn't properly installed within apache2, so how can I reinstall it without causing any damage to the customers websites?
     
  2. rvarkevisser

    rvarkevisser New Member

    Hi there,

    I have a problem and I can not figure out how to solve this. I've been at it for the last three weeks and still don't have a solution. Here's the problem

    http://www.la-capirinha.nl/test.htm

    The Euro, apostrophe etc. are all shown as squares when converted from a different charset (like windows-1252). I use apache2.0.54 with ISPConfig. The OS is Debian Etch Stable. When using utf-8 as the coding for the page, it works perfectly.

    http://www.la-capirinha.nl/test2.htm

    I have another server which runs Debian Sarge stable and here every thing is fine. The problem is that on the Debian Edge server, I have around 130 customer websites running. So I really need a solution!
     
  3. Hans

    Hans Moderator ISPConfig Developer

    You can try to enable more locales by giving the command:

    dpkg-reconfigure locales

    Choose the locales you need.
    Probably this will work for you.
     
  4. rvarkevisser

    rvarkevisser New Member

    Hans,

    I matched the LANG and every setting in locale to the server where it does work correctly. After restarting apache2 it looks fine now. The strange think is that I had to set it to POSIX.

    LANG=POSIX
    LC_CTYPE="POSIX"
    LC_NUMERIC="POSIX"
    LC_TIME="POSIX"
    LC_COLLATE="POSIX"
    LC_MONETARY="POSIX"
    LC_MESSAGES="POSIX"
    LC_PAPER="POSIX"
    LC_NAME="POSIX"
    LC_ADDRESS="POSIX"
    LC_TELEPHONE="POSIX"
    LC_MEASUREMENT="POSIX"
    LC_IDENTIFICATION="POSIX"
    LC_ALL=

    Don't ask me why ??? but it works for now. I managed to get it working once, but after a few nights, the problem was back. (probably after a restart of apache)
     

Share This Page