/usr/bin not in PATH for PHP-FPM?

Discussion in 'Installation/Configuration' started by darkangel, Mar 19, 2013.

  1. darkangel

    darkangel New Member

    Hi,

    When I switched to PHP-FPM, I couldn't run the "java" executable (in PHP code). I'm assuming it's because /usr/bin is not in the PATH, but how do I fix this?

    Thx.
     
  2. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    I think it's an open_basedir problem. Please add /usr/bin to open_basedir on the Options tab of the website.
     
  3. darkangel

    darkangel New Member

    It was because PHP-FPM was not set up correctly (see here).

    Thx.
     

Share This Page