Using web site as reverse Proxy, get server error 500

Discussion in 'Installation/Configuration' started by muekno, Dec 20, 2020.

  1. muekno

    muekno Member HowtoForge Supporter

    I followed https://www.howtoforge.com/community/threads/ispconfig-with-reverseproxy.78182/
    My modified Apache Options in the Option Tabs are below, as I not have SSL by now
    Code:
    #RewriteEngine On
    #RewriteCond %{HTTPS} off
    #RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI}
    #SSLProxyEngine On
    RequestHeader set Front-End-Https "On"
    ProxyPreserveHost On
    ProxyRequests Off
    ServerName gwmail.muekno.de
    #ServerAlias controlpanel.ispcp.domain.name
    ProxyPass / https://172.16.1.232/
    ProxyPassReverse / https://172.16.1.232/
    <Proxy *>
    Order deny,allow
    Allow from all
    </Proxy>
    
    If I open https://172.16.1.232/ (the target) everything works fine
    Till now I had a separate server outside the ISPconfig servers that works fine too with this configuration
    Code:
    <Virtualhost 172.16.1.241:80>
    ServerName gw.gerdakloos.de
    ServerAdmin [email protected]
    ProxyPreserveHost On
    DocumentRoot /var/www/html
    ProxyPass /.well-known !
    ProxyPass / http://gw2.gerdakloos.de/ retry=0 disablereuse=On
    ProxyPassReverse / http://gw2.gerdakloos.de/
    
    ##RewriteEngine on
    ##RewriteCond %{SERVER_NAME} =gw.gerdakloos.de
    ##RewriteRule ^ https://%{SERVER_NAME}%{REQUEST_URI} [END,NE,R=permanent]
    RewriteEngine on
    RewriteCond %{SERVER_NAME} =gw.gerdakloos.de
    RewriteRule ^ https://%{SERVER_NAME}%{REQUEST_URI} [END,NE,R=permanent]
    </Virtualhost>
    
    The reason is this server does nothing than proxy and I want to get rid of is, to save RAM on my ESXi, so as there is a webserver in my ISPconfig3 multiple server system, why not user an additional website as proxy.
    This configuration has a working letsencrypt certificate too, what ist planed for the new proxy too.
    What I do not know, there is nothing in the tutorial , what to do with the default generated index.html
    These thread https://www.howtoforge.com/community/threads/use-ispconfig-as-reverse-proxy.78308/ does not help too
    running ISPconfig 3.2 on Debian 10 latest patches, mod_proxy and mod_proxy_http are installed and enabled.
    Need help hint
    Thanks
    Rainer
     
    Last edited: Dec 20, 2020
  2. muekno

    muekno Member HowtoForge Supporter

    Sorry I mixed some IP addresses, correcting this leads to other problems.
    But any hint to my configuration is wellcome
     
  3. muekno

    muekno Member HowtoForge Supporter

    Have istalled a certificate now and uncomendet the relvant lines. still problems but not ISPconfig relevant
    Sorry to disturb you
    Happy Christmas and a better new Year than ist was 2020
     
  4. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    Don't worry and if you do have any questions don't hestitate to ask them.
    Let's hope we have a better year :D
     

Share This Page