Using Ruby On Rails With Apache2 On Debian Etch

Discussion in 'HOWTO-Related Questions' started by zakalwe, Oct 10, 2007.

  1. zakalwe

    zakalwe New Member

    Hi,

    I just followed the RoR with Apache2 on Debian tutorial to setup a rails based vhost on my existing Apache 2 server.
    I followed the instructions to the letter and everything went fine until I tried to look at the site :/

    I can see the "Welcome Aboard" page OK but when I click on the "About your application's environment" link I get the following error:
    Code:
    Routing Error
    
    Recognition failed for "/rails/info/properties"
    (screenshot attached)

    The following is dumped in the /log/development.log file:
    Code:
    Processing Base#index (for nnn.nnn.nnn.nnn at 2007-10-10 10:17:53) [GET]
      Session ID: 6e050ec9b64a69144063d5900ce438c5
      Parameters: {}
    
    
    ActionController::RoutingError (Recognition failed for "/rails/info/properties"):
        /vendor/rails/actionpack/lib/action_controller/routing.rb:522:in `recognition_failed'
        /vendor/rails/actionpack/lib/action_controller/routing.rb:512:in `recognize!'
        /vendor/rails/railties/lib/dispatcher.rb:38:in `dispatch'
        /vendor/rails/railties/lib/fcgi_handler.rb:150:in `process_request'
        /vendor/rails/railties/lib/fcgi_handler.rb:54:in `process!'
        /usr/lib/ruby/1.8/fcgi.rb:612:in `each_cgi'
        /usr/lib/ruby/1.8/fcgi.rb:609:in `each'
        /usr/lib/ruby/1.8/fcgi.rb:609:in `each_cgi'
        /vendor/rails/railties/lib/fcgi_handler.rb:53:in `process!'
        /vendor/rails/railties/lib/fcgi_handler.rb:23:in `process!'
    /path/to/domain.com/public/dispatch.fcgi:26
    Any ideas on what might be going wrong?

    Thanks
    Simon
     

    Attached Files:

  2. falko

    falko Super Moderator ISPConfig Developer

    Please compare your configuration with the one from the tutorial. Maybe you made a typo somewhere?
     
  3. zakalwe

    zakalwe New Member

    Originally I ran the tutorial and changed the directory because I keep all the virtualhosts on my server in /home/me/domains/somedomain.com
    Then I went through it again, using the same directory as the tutorial, and got the same error. I spent a couple of hours checking, re-checking and googling error messages before I posted here ;)

    I think the version may have been the problem. I removed ruby with apt because Etch installs 1.1.6 and installed the latest version with RubyGems instead and now it seems to be OK. Now I get the following message:
    Code:
    For security purposes, this information is only available to local requests.
    Once I get around to copying the site I'm working on from my computer to the server I'll post back here and let you know if that fixed it :)
     
  4. zakalwe

    zakalwe New Member

    Yep, all works fine now - installing a newer version of Ruby fixed it :)
     

Share This Page