Using php5.6 in ISPconfig environment

Discussion in 'ISPConfig 3 Priority Support' started by Roch, Dec 6, 2019.

  1. Roch

    Roch New Member HowtoForge Supporter

    I've followed the tutorial How to install PHP 7.1, 7.2 and 5.6 as PHP-FPM & FastCGI for ISPConfig 3 on Debian 9.pdf
    When I create a website with PHP-FPM and php 5.6, I get: ERROR 503 - Service Unavailable!
    I can't understand why.

    When I create the same website with Fast-CGI and php 5.6 and using phpversion, I get a correct answer: Version PHP courante : 5.6.33.

    Unfortunately I need PHP 5.3 and PHP 5.4 in the same ISPconfig configuration.
    Is there a tutorial to install these versions ?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Might be that the php-fpm dameon is not started or could not be restarted. If your server is using systemd as init system, which is most likely the case today, then it's important that you started the php fpm daemon for the new php version by using systemctl or service command and not by using an init script in /etc/init.d, if you would use an init script, then php-fpm can not be restarted when PHP mode is changed in the website which makes PHP fail.

    No. Basically the steps to install them is similar to the ones you used for PHP 5.6, but it might be that you run into trouble with openssl versions as these php versions might not compile correctly against a recent openssl. This means that one might have to compile an old openssl manually in a different directory and then use that to compile the old php.
     

Share This Page