Using custom php version with roundcube

Discussion in 'ISPConfig 3 Priority Support' started by pawan, May 19, 2017.

  1. pawan

    pawan Member HowtoForge Supporter

    I am using Ubuntu 12.04.
    The default php version is 5.3.10, but I have custom php versions installed and working like 5.4 and 7
    Now for the roundcube installation I want to use PHP5.4 or PHP7.
    Roundcube is installed as vhost in /VAR/www directory.
    and roundcube.conf is in /etc/apache2/conf.d

    Where and what changes I can make to enable roundcube to use custom PHP Version.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    That's not so easy because roundcube runs with mod_php and the mod_php module is the one of your system PHP. you can e.g. create a new website mail.yourdomain.tld in ISPConfig and install a separate roundcube copy into that site.
     

Share This Page