Using cgi-bin directory outside ispconfig installation

Discussion in 'Installation/Configuration' started by menahem, Nov 14, 2010.

  1. menahem

    menahem Member

    Hi all,

    As you all know ispconfig uses jalkit in order to chroot web-server as well as mail server erc. That is fine, but: i am experiencing a problem with other application we use cgi-bin directory outside the chrooted system.

    In order to pin-point the problem i will give 2 examples (one solved and one did not)

    Example 1 mailgraph (This tutorial --> http://howtoforge.net/mail_statistics_mailgraph_pflogsumm):
    Mailgraph installation put out cgi-bin files at:/usr/lib/cgi-bin/. If you use the tutorial you will not see any graph because the web-site user is jailed under the web-site directory. In this case i re owned the files at /usr/lib/cgi-bin/ to the web-server user (i.e webX.clentY) and it worked out fine.

    Example 2 BackupPC: (this tutorial --> http://howtoforge.net/linux_backuppc) once again cgi-bin files are outside the chrooted web server. I build up the web server user at backuppc installation but it is not working at all.

    Another problematic app is nagios who ,once again, put cgi-bin directive out side the chrooted system, and once again (although i owned the cgi-bin directory to web server jailed user) it is not usable.

    I will be more the happy if some one has a way howto fix the problem of cgi-bin outside the chrooted web-server user.

    B.T.W: in the case of nagios i chaned the apache.conf file that came with the installation so that it will point to the chrooted cgi-bin and made the other needed changes with nagion, never the less it did not worked out nagios did not liked is. I think their should be more system wise solution so that jailed web-site user could read run and activate cgi-bin directories out side jail.

    A word about the installation:

    O.S: Ubuntu 10.04.1 32 bit web server.Ispconfig3 version 3.0.3

    Thank you all,

    Menahem
     
  2. jconstantino

    jconstantino New Member

    Same problem...

    Hi, same problem here...
    I'm using ISPConfig2 and Nagios3...any help?
    Thanks in advance
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post your question in the ispconfig 2 subforum.

    ISPConfig 2 and 2 are completely different software packages. So any solution for ispconfig 2 will not work for ispconfig 3 and vice versa.
     
  4. jconstantino

    jconstantino New Member

    Sorry, I didn't notice this was an ISPConfig3 forum (came from search engine...)
    I've checked ISPConfig2 forum, and found no solution...
    Thank you for a great great site!
     
  5. adig

    adig New Member

    Hello,

    I know we are in 2013 but I couldn't find anywhere this info:

    Is there a solution so I can have ISPConfig and Nagios on the same server?



    ""Another problematic app is nagios who ,once again, put cgi-bin directive out side the chrooted system,"
    "

    Thank you in advance.
     
  6. jconstantino

    jconstantino New Member

    My solution

    Hi,

    I've manage to use Nagios3 with ISPConfig2...I think that this is not a "clean and beautiful" solution, but maybe you can give it a try (replace webXXXX with your virtual server folder):

    copy nagios3 cgi to /var/www/webXXX/cgi-bin/nagios3

    in nagios3.conf I have:

    ScriptAlias /cgi-bin/nagios3 /var/www/webXXX/cgi-bin/nagios3
    ScriptAlias /nagios3/cgi-bin /var/www/webXXX/cgi-bin/nagios3

    and

    <DirectoryMatch (/usr/share/nagios3/htdocs|/var/www/webXXX/cgi-bin/nagios3|/etc/nagios3/stylesheets)>
    Options FollowSymLinks +ExecCGI
    DirectoryIndex index.php
    AddHandler cgi-script .cgi .pl
    AllowOverride AuthConfig
    Order Allow,Deny
    Allow From All

    AuthName "blablabla..."
    AuthType Basic
    AuthUserFile /etc/nagios3/<file users>

    require valid-user
    </DirectoryMatch>

    Hope this can help...

    Regards,
    Joao Constantino
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Just a note: ISPConfig 2 and 3 are completely different controlpanels, so a setup for ispconfig 2 will not work for ispconfig 3 as the paths and apache setup is different.
     
  8. jconstantino

    jconstantino New Member

    ISPConfig2 is not ISPConfig3...

    I'm aware that ispconfig2 and ispconfig3 are diferent (that's why I started to explicity state that my workaround worked for me with ispconfig2...)

    I was trying to point a possible path...

    Sorry for any inconvenient...

    Regards,
    Joao Constantino
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Thanks for posting your configuration and it will be helpful for a user with ispconfig for sure.

    The paths for ispconfig 3 are:

    /var/www/clients/client[CLIENTID]/web[WEBID]/cgi-bin/
     
  10. adig

    adig New Member

    Oh my God, it's working... :)

    Thank you so much!
     

Share This Page