using 2.2.5, need to downgrade to mysql4 and php <= 5.2.3

Discussion in 'Installation/Configuration' started by st2xo, Sep 23, 2008.

  1. st2xo

    st2xo New Member

    Hi there .... for a new installation (no upgrade) with ISPConfig 2.2.5 on opensuse11.0 I have to downgrade the installed versions mysql 5.0.51a to mysql 4.x and php5.2.6 to php5.2.3 or older.
    On this new installed machine will be run an "Oxid Shop" see here for installation requirements (in german)

    My first idea is to remove (e.g. with yast) the mysql- and php-packages and install the recommended, older versions. Would that be the best and easiest way? Are there any problems to expect with this way?

    The ISPConfig-Configuration with webs, users etc. and the whole server are ready to run. To backup this data, I would create a mysql5-dump in mysql4-Format and reload it into the new system (if the package-remove and re-install would work).

    :eek:Always check software-requirements before you setup a new system :D


    What do you mean?
    Is there anybody who did this already?
    Thanks for hints!!!
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Maybe you should tell them that they were stressing the truth a bit much on their internet site ;)

    For all non german speaking poeple "The OXID Shop is based on the latest Internet technologoies."

    they should have written "The OXID shop does not support the latest Internet technologies."

    But back to the problem.

    I dont see many other alternatives beside that. But I guess you will have to install php and mysql from source or another location, as suse might not provide packages for the mysql and php versions that you need.
     
  3. Grey

    Grey New Member

    Besides that, the new versions have their reason. And in the case of php the security flaws fixed would let me think twice - and they seem to forget, that PHP 5.2.3 is from July, 2007. That's - like Till quoted - "not the latest internet technology". I tend to say it's quite careless to state such things for a product like an eShop (that should be rather very secure).

    Edit: It only states "not PHP 5.2.4", but there's no mentioning of 5.2.5 or 5.2.6?
    Edit2: "Abschaltung des safe_mode und kein gesetztes open_basedir" - I think that will take you to another problem, as ISPConfig can disable safe_mode, but open_basedir is always set if you install it without changing the php_wrapper or alike, isn't it?
     
    Last edited: Sep 24, 2008
  4. st2xo

    st2xo New Member

    before de- and re- and new-installings to older versions of php and mysql I tried to run the oxid-shop with the php/mysql-versions coming with ISPConfig 2.2.5 - and it works! With a little luck there will be no problems ....

    Thanks to you both!
     

Share This Page