users problems

Discussion in 'General' started by matrixn, Apr 20, 2012.

  1. matrixn

    matrixn New Member

    i have a problem with my ispconfig 2.2.39 instalation on a opensuse 11.4 machine.

    The problem started few days ago when i was creating and changing passwords for users emails. the problem was that i couldn`t login into my machine with root user... after some digging and googleing... i find out that my /etc/passwd, /etc/group and /etc/shadow where empy... so i create the users and groups from backups but the ispc users and groups where not in backup so i had to create them manualy and map them to correct uids/gids.

    so far evrything works... exept that if i change at least one password from ispc admin, all my group, shadow and passwd files are incompletly filled and sometimes the system users like root are missing... is there a way to fix this?
     
    Last edited: Apr 20, 2012
  2. falko

    falko Super Moderator

    Please upgrade to 2.2.40 and try again.
     
  3. Numerizen

    Numerizen HowtoForge Supporter

    Didn't notice this message before posting this one : http://www.howtoforge.com/forums/showthread.php?t=57268, which basically describes the same problem.

    May I ask if the upgrade is safe even after the problem appeared ?

    Second question : what is the safer, and if possible automatic way to restore all the data in these files ? I read about some writeconf script but the thread was rather old so didn't dare to try.

    Last question : should these files be backed up, as they're quite important but the information in it should remain confidential, so maybe it's not a good idea to replicate it ?

    Last question number two : is there a known origin to this problem, or is it complete random ? I asked the question about an unusual (for me) domain name, but it's only an uneducated guess.

    Please help this poor soul who fears to touch anything since its world crumbled down two days ago.
     
    Last edited: May 12, 2012

Share This Page