USernames with a Number

Discussion in 'Installation/Configuration' started by kassie, Aug 8, 2007.

  1. kassie

    kassie New Member

    Hi Guys,

    I upgraded to 2.2.15 so i can use usernames that start with a number.

    I have 2 domains for 1 client.
    firstseal.co.za & 1stseal.co.za

    All the mail sent to 1stseal.co.za must get forwarded to firstseal.co.za.

    When the mail get to my server it does this, i copied out the mail.log
    I don't get a mail back saying there was an error, nor does the mail go through??

    I also cannot log in to the 1stseal accounts via webmail....
    Any suggestions.
     
    Last edited: Aug 8, 2007
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    This has nothing to do with usernames. It just means that the server mail.1stseal.co.za is not reachable or no mail server is started on the system.
     
  3. kassie

    kassie New Member

    Hi Till,

    I have just over 50 domains on that server. all the rest works. It's only that one domain...

    I don't know why??

    Here is a little more than just the error to show the server is working.
     
    Last edited: Aug 9, 2007
  4. kassie

    kassie New Member

    Any news??
     
  5. falko

    falko Super Moderator ISPConfig Developer

    Is 196.36.108.11 your server's IP address? Please make sure that the MX record for 1stseal.co.za points to the same server as all your other domains.
     
  6. kassie

    kassie New Member

    Hi Falko,

    I checked that first. The mail is coming there, but just times out...
     
  7. falko

    falko Super Moderator ISPConfig Developer

    I think I've found the problem:

    Code:
    mh1:~# dig mx 1stseal.co.za
    
    ; <<>> DiG 9.2.1 <<>> mx 1stseal.co.za
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 38187
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;1stseal.co.za.                 IN      MX
    
    ;; ANSWER SECTION:
    1stseal.co.za.          3600    IN      MX      5 [B][COLOR="Red"]196.36.108.11.[/COLOR][/B]
    
    ;; Query time: 210 msec
    ;; SERVER: 213.191.92.84#53(213.191.92.84)
    ;; WHEN: Fri Aug 10 16:20:50 2007
    ;; MSG SIZE  rcvd: 60
    
    mh1:~#
    The MX record points to an IP address, but it must point to an FQDN (compare the dig output for firstseal.co.za:

    Code:
    mh1:~# dig mx firstseal.co.za
    
    ; <<>> DiG 9.2.1 <<>> mx firstseal.co.za
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 33635
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1
    
    ;; QUESTION SECTION:
    ;firstseal.co.za.               IN      MX
    
    ;; ANSWER SECTION:
    firstseal.co.za.        3600    IN      MX      5 mail.firstseal.co.za.
    
    ;; ADDITIONAL SECTION:
    mail.firstseal.co.za.   3600    IN      A       196.36.108.11
    
    ;; Query time: 231 msec
    ;; SERVER: 213.191.92.84#53(213.191.92.84)
    ;; WHEN: Fri Aug 10 16:20:34 2007
    ;; MSG SIZE  rcvd: 70
    )
     

Share This Page