username already in use

Discussion in 'Installation/Configuration' started by confighelp, Nov 9, 2007.

  1. confighelp

    confighelp New Member

    I am triying to add one user "msp". But it says "username already in use. But there is no such user. I have checked all the database , /etc/passwd, /etc/group, /home/admispconfig/users,/etc/postfix/vitusertable, /etc/aliases, every possible location. But could not find anywhere. Does ISPconfig have any reserved username ?
  2. edge

    edge Active Member Moderator

    I just tested it, and had no problem adding a user named: msp
    So.. It's not a reserved username..

    Did you have a look in the ISPconfig's Recycle Bin(s) ?
    If msp is in it, restore or delete it.
  3. falko

    falko Super Moderator ISPConfig Developer

    Please check /home/admispconfig/ispconfig/users.
  4. modmon

    modmon New Member

    I have exactly the same problem with Debian 4.0 R3 Etch and ISPConfig

    I try to add the user "ian" and it says "username already in use".

    I have checked every location as above and there is no user with that name.
    I even re-installed the OS and ISPConfig and tried adding this user first and it still says the same thing!

    This must be a reserved username possibly, anybody?
  5. falko

    falko Super Moderator ISPConfig Developer

    Did you check all recycle bins and /home/admispconfig/ispconfig/users and /etc/passwd?
  6. modmon

    modmon New Member

    yes, did all that, like i said, even tried formatting the drive and reinstalling Debian 4 and then a fresh install of the latest ISPConfig so that there would be no users apart from root and an admin. Tried adding the user "ian" and it gives the error "username already in use" but of course there is no such user.
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post the output of:

    grep ian /etc/passwd
  8. modmon

    modmon New Member

  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok. Is the username ian listed in the file:


    if yes, delete it from there.
  10. modmon

    modmon New Member

    No, its not in there and I have checked all these locations too:

    /etc/passwd, /etc/shadow, /etc/group, /home/admispconfig/users,/etc/postfix/vitusertable, /etc/aliases

    I have not created the user in the past and then deleted it so it has never been in the recycle bin.

    Like I said, I formatted the drive and reinstalled Debian as the Howto perfect server etc. and then installed ISPconfig and it still wont let me add the user 'ian'.

    Its interesting though as I tried do the same thing only using Ubuntu 7.10, and then I can add the user without a problem :confused:
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    Which username prefix do you use? Is there a record for the user ian in the ispconfig mysql database table isp_isp_user?
  12. modmon

    modmon New Member

    No record for that user in that table, or any of the other tables in the ISPCOnfig database.

    I dont use a prefix, I just remove it in the settings to allow just the username to be entered.
  13. till

    till Super Moderator Staff Member ISPConfig Developer

    It is highly recommended to use the user prefix. Removing it may cause errors.Please add the username prefix again or use a longer username.

Share This Page