Userdir plugin not working

Discussion in 'HOWTO-Related Questions' started by Sotiris.k, Sep 4, 2012.

  1. Sotiris.k

    Sotiris.k New Member

    Hello all,

    I installed ISPConfig 3 on a home server for personal use which is on dynamic IP and therefore can not work as a DNS Server and use FQDN.

    So my goal was to use the websites that I setup through http://home_server_ip/website.domain

    I did some research on it and discovered the userdir plugin http://www.howtoforge.com/userdir-access-on-ispconfig-3-server and installed it.

    I have the "Temporary URL" enabled for any website but the result is still just a 403 Forbidden page.

    So to all of you who run ISPConfig for a similar purpose and may or may not have tried this plugin, I would like some directions on how to fix my problem.

    Thank you!
     
    Last edited: Sep 4, 2012
  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. Sotiris.k

    Sotiris.k New Member

    I can access my server perfectly with just the IP. That's not my problem.

    My problem is how to access a website created with ISPConfig on said server.

    Example: I create 2 websites called domain1.com and domain2.com but of course I am not the owner of said domains since they are just dummies.

    Is there a way to access the websites created on my server for those domains?

    Like this http://192.168.0.100/domain1.com
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, I posted the link that describes this in detail. AgĀ“fetr you followed the description in the faq, you can access your sites as if they exist in dns like http://domain1.com as the hosts file on your workstation overrides the normal dns system for your computer. You can ecen use fake domains with another tld like .int for internal so that you dont mix them up with external websites.

    The userdir module is mostly for plain html pages and I wont use it personally as it wornt work for pages with scripts or cms systems anyway.
     
  5. Sotiris.k

    Sotiris.k New Member

    It worked! Thanks :)
     
  6. MaddinXx

    MaddinXx Member HowtoForge Supporter

    Hi @Sotiris.k

    I'm sorry the plugin didn't work for you, but I'm interested in discovering why it didn't so I can improve it if needed.

    You were only trying it with an IP as "default vhost", e.g. the base for the userdirs config as I can see, is this right?

    Thanks for your answer!
    Regards
     
  7. Sotiris.k

    Sotiris.k New Member

    Hi Maddinxx,

    Yes i was using it like this http://192.168.0.1/domain1.com
    The IP was of course the IP of my home server and the domain was correctly setup through ISPConfig

    I followed the directions step by step. Tell me what would you be interested to see from me so I can help the debug (if there is any and it's not my fault)
     
  8. MaddinXx

    MaddinXx Member HowtoForge Supporter

    I just tried the plugin following the tutorial step by step and there was a typo within one of the "cp" commands, not using absolute paths (e.g. /) - this could be reason for why it wasn't working for you.

    Also, did you use ~ (tilde) before the "URL", e.g. http://ip/~domain.tld? It seems you missed it.

    Other reasons could be mod_security etc. but that's wild guessing.

    Anyway, like till mentioned, the plugin is only useful for static pages - so if you want to run PHP it's not possible :)
     
  9. Sotiris.k

    Sotiris.k New Member

    I noticed the error on the cp command and typed it correctly at the time, so it's not this problem.

    Although I didn't notice the "~" and went to check again now but still I couldn't see it.

    Nevertheless, I managed to access the site by messing with the hosts file on my client terminal as was suggested beforehands.
     

Share This Page