User Policy At vsftpd Server

Discussion in 'Server Operation' started by Sinchan, Nov 20, 2006.

  1. Sinchan

    Sinchan New Member

    Hi all, I am a new members on this forum...
    I had a problem when configure user policy at my vsftpd server...
    My user policy is like this :
    - User A : at own home directory had sub folder A1 and A2
    - User B : at own home directory had sub folder B1 and B2
    - User C : have an access read privillage at folder A1 and B1
    - User D : have an access read privillage at folder A2 and B2
    For user A and B, its work.. but i got a problem to manage user C and D.
    How i can set that policy user like that? plz... give me advice or reference bout that?
    First time .. i used symbolic link (ln) to do that, but it's not work when i access my ftp from ftp browser such as firefox. From firefox seen that seen like a file ln, not a sub folder.
    Im sorry if my english is so badly... :)
    Thank you...
     
  2. falko

    falko Super Moderator ISPConfig Developer

    If you use system users, you must disable the chroot feature in /etc/vsftpd.conf. But keep in mind then that every user can browse all directories on the server!
     
  3. Sinchan

    Sinchan New Member

    Mr. Falco...
    How to disable the chroot feature in /etc/vsftpd.conf ? As I know, default setting on vsftpd server, must use that config file.
    About user policy, absolutely i dont want every user can browse all my directory on the server, of course .. ;) No body want to do that.
    Can you give me another way to do that please ?
    By the way thanks for your advice, i am googling an howto about configuration setting for vsftpd server periodically, but i never found explanation about my problem.. Once again thanks for your advice :)
     
    Last edited: Nov 23, 2006
  4. falko

    falko Super Moderator ISPConfig Developer

    What's in your vsftpd.conf?

    I don't know of any other way now... :(
     

Share This Page