User & Email

Discussion in 'General' started by Kayov, Aug 17, 2006.

  1. Kayov

    Kayov New Member

    Hi, i got a little problem here, when i create a site and then try to add a new ftp/email user it all works fine.
    I coonfigure it with outlook and still all good, but as soon as i send an email to that acount, the server begins to send several emails to that acount, "like spam" :) ....
    The process that i see always running is this one:
    /bin/sh -c wc -c | formail -A"X-Loop: ${LOGNAME}@localhost.localdomain" \?

    And the mails i revice are always the same:

    From: MAILER-DAEMON@server1.pigeonsmanager.com
    Subject: Undelivered Mail Returned to Sender
    Text:

    This is the Postfix program at host server1.pigeonsmanager.com.

    I'm sorry to have to inform you that your message could not
    be delivered to one or more recipients. It's attached below.

    For further assistance, please send mail to <postmaster>

    If you do so, please include this problem report. You can
    delete your own text from the attached returned message.

    The Postfix program

    <admispconfig@localhost.localdomain.pigeonsmanager.com>: mail for
    localhost.localdomain.pigeonsmanager.com loops back to myself


    Any idea?

    Best regards,
    Ivan Silva
     
  2. till

    till Super Moderator

    Please add the line:

    localhost.localdomain.pigeonsmanager.com

    at the end of the file:

    /etc/postfix/local-host-names

    and restart postfix:

    /etc/init.d/postfix restart
     
  3. Kayov

    Kayov New Member

    Just did it, the problem is that as soon as i add a new ftp/email user the ispconfig rewrites the /etc/postfix/local-host-names file and erase the line u told me to add.
     
  4. Kayov

    Kayov New Member

    I changed the /etc/postfix/local-host-names after adding the user and everything just goes fine, no more email loop send.
    But 1 problem persists, as i add a new user, the /etc/postfix/local-host-names is rewrite and erase the good solution line.
     
  5. falko

    falko Super Moderator

    You must add the line at the end of /etc/postfix/local-host-names, where it says that you are allowed to make your changes.
     
  6. Kayov

    Kayov New Member

    Thanks a lot, i should ad figured it out!
    By the way, another question:

    since i instaled ISPConfig, every time that i reboot my system, apache is running, ipconfig tell me that apache is running but i cant connect to port 80, if i use the ispconfig tool to restart the service, it begins to work just fine.
    Any ideia?
     
  7. falko

    falko Super Moderator

    Any errors in Apache's error log? What's the output of
    Code:
    netstat -tap
    when this happens?
     
  8. Kayov

    Kayov New Member

    Ok, i'll show you step by step what happends:

    ** Just after a reboot **

    [root@server1 ~]# telnet localhost 80
    Trying 127.0.0.1...
    Connected to localhost.localdomain (127.0.0.1).
    Escape character is '^]'.

    Works fine!

    [root@server1 ~]# telnet 217.129.217.126 80
    Trying 217.129.217.126...

    This is my public IP, doest work!

    Apache error_log:

    [Sat Aug 19 13:11:07 2006] [notice] caught SIGTERM, shutting down
    [Sat Aug 19 13:11:10 2006] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
    [Sat Aug 19 13:11:11 2006] [notice] Digest: generating secret for digest authentication ...
    [Sat Aug 19 13:11:11 2006] [notice] Digest: done
    [Sat Aug 19 13:11:11 2006] [notice] mod_python: Creating 4 session mutexes based on 256 max processes and 0 max threads.
    [Sat Aug 19 13:11:12 2006] [notice] Apache/2.2.0 (Fedora) configured -- resuming normal operations

    netstat -tap:

    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 *:mysql *:* LISTEN 1720/mysqld
    tcp 0 0 *:55791 *:* LISTEN 1347/rpc.statd
    tcp 0 0 *:sunrpc *:* LISTEN 1328/portmap
    tcp 0 0 server1.pigeonsmanage:50000 *:* LISTEN 1563/hpiod
    tcp 0 0 *:hosts2-ns *:* LISTEN 2180/ispconfig_http
    tcp 0 0 server1.pigeonsmanage:50002 *:* LISTEN 1568/python
    tcp 0 0 192.168.0.2:domain *:* LISTEN 2305/named
    tcp 0 0 server1.pigeonsmanag:domain *:* LISTEN 2305/named
    tcp 0 0 server1.pigeonsmanager.:ipp *:* LISTEN 1580/cupsd
    tcp 0 0 server1.pigeonsmanager:rndc *:* LISTEN 2305/named
    tcp 0 0 *:smtp *:* LISTEN 2277/master
    tcp 0 0 server1.pigeonsmanage:50000 server1.pigeonsmanage:43766 ESTABLISHED 1563/hpiod
    tcp 0 0 server1.pigeonsmanage:43766 server1.pigeonsmanage:50000 ESTABLISHED 1568/python
    tcp 0 0 *:imaps *:* LISTEN 1766/dovecot
    tcp 0 0 *:pop3s *:* LISTEN 1766/dovecot
    tcp 0 0 *:pop3 *:* LISTEN 1766/dovecot
    tcp 0 0 *:imap *:* LISTEN 1766/dovecot
    tcp 0 0 *:http *:* LISTEN 2206/httpd
    tcp 0 0 *:ftp *:* LISTEN 2322/proftpd: (acce
    tcp 0 0 *:ssh *:* LISTEN 1609/sshd
    tcp 0 0 ::1:rndc *:* LISTEN 2305/named
    tcp 0 0 *:https *:* LISTEN 2206/httpd
    tcp 0 1332 ::ffff:192.168.0.2:ssh sm-217-129-217-154.ne:xaapi ESTABLISHED 1621/1

    ** Now i just entered ispconfig at port 81 and restart Web Server with the services tool **

    [root@server1 ~]# telnet 217.129.217.126 80
    Trying 217.129.217.126...
    Connected to sm-217-129-217-126.netvisao.pt (217.129.217.126).
    Escape character is '^]'.

    Works fine now....

    Apache error_log:

    [Sat Aug 19 13:19:18 2006] [notice] caught SIGTERM, shutting down
    [Sat Aug 19 13:19:19 2006] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
    [Sat Aug 19 13:19:19 2006] [notice] Digest: generating secret for digest authentication ...
    [Sat Aug 19 13:19:19 2006] [notice] Digest: done
    [Sat Aug 19 13:19:19 2006] [notice] mod_python: Creating 4 session mutexes based on 256 max processes and 0 max threads.
    [Sat Aug 19 13:19:20 2006] [notice] Apache/2.2.0 (Fedora) configured -- resuming normal operations

    netstat -tap:

    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 *:mysql *:* LISTEN 1720/mysqld
    tcp 0 0 *:55791 *:* LISTEN 1347/rpc.statd
    tcp 0 0 *:sunrpc *:* LISTEN 1328/portmap
    tcp 0 0 server1.pigeonsmanage:50000 *:* LISTEN 1563/hpiod
    tcp 0 0 *:hosts2-ns *:* LISTEN 2180/ispconfig_http
    tcp 0 0 server1.pigeonsmanage:50002 *:* LISTEN 1568/python
    tcp 0 0 192.168.0.2:domain *:* LISTEN 2305/named
    tcp 0 0 server1.pigeonsmanag:domain *:* LISTEN 2305/named
    tcp 0 0 server1.pigeonsmanager.:ipp *:* LISTEN 1580/cupsd
    tcp 0 0 server1.pigeonsmanager:rndc *:* LISTEN 2305/named
    tcp 0 0 *:smtp *:* LISTEN 2277/master
    tcp 0 0 server1.pigeonsmanage:50000 server1.pigeonsmanage:43766 ESTABLISHED 1563/hpiod
    tcp 0 0 server1.pigeonsmanage:43766 server1.pigeonsmanage:50000 ESTABLISHED 1568/python
    tcp 0 0 *:imaps *:* LISTEN 1766/dovecot
    tcp 0 0 *:pop3s *:* LISTEN 1766/dovecot
    tcp 0 0 *:pop3 *:* LISTEN 1766/dovecot
    tcp 0 0 *:imap *:* LISTEN 1766/dovecot
    tcp 0 0 *:http *:* LISTEN 2784/httpd
    tcp 0 0 *:ftp *:* LISTEN 2322/proftpd: (acce
    tcp 0 0 *:ssh *:* LISTEN 1609/sshd
    tcp 0 0 ::1:rndc *:* LISTEN 2305/named
    tcp 0 0 *:https *:* LISTEN 2784/httpd
    tcp 0 1776 ::ffff:192.168.0.2:ssh sm-217-129-217-154.ne:xaapi ESTABLISHED 1621/1
     
  9. falko

    falko Super Moderator

    I guess this is a problem with your router... Maybe it needs some time until it works. :confused: Your Apache seems to be fine.
     
  10. Kayov

    Kayov New Member

    Thanks for all the help, i dont know why but now it works, i guess maybe the problem was the same as the user/email creation and now its working....

    Thanks again.
     

Share This Page