user does not have write permission

Discussion in 'Installation/Configuration' started by Dznet, Oct 24, 2018.

  1. Dznet

    Dznet New Member

    Hello,
    sorry, but my english is not very good.
    I have a new VPS where I install ISPc3.
    I set up a new DotClear site.
    The problem is that the Client1 user does not have write permission.
    When I look at the PHP User here is what I find:
    get_current_user () = root
    print_r (exec ('whoami') = www-data

    How to solve this problem ?
    For now, for the site to work I give the right to write to all: a + w
    that's not really good.
    Thank you for your help
     
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    When setting up website, tick SuEXEC.
    Use the FTP or SSH user set up for that website to write files there.
    Then website files have correct permissions and the web server runs as a user that has the necessary access rights.
     
    Jesse Norell likes this.
  3. Jesse Norell

    Jesse Norell Well-Known Member

    I believe @Taleman's response pertains to fastcgi php mode; another solution is to use php-fpm.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    The suexec option applies to all PHP modes except mod_php. So php-fpm and fastcgi are both fines as php modes.
     
  5. Dznet

    Dznet New Member

    Thank you for your answers

    suEXEC is ticked, and I do FTP file transfer with the right user.
    I have been using ISPc for a long time, but I have never had this problem.

    even when php-fpm matt it does not work
     
  6. Dznet

    Dznet New Member

    it's the same result with fast-cgi or php-fpm
    when I run the site, I get an error message, it can not access the cache
     
  7. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Where is this cache?
     
  8. Jesse Norell

    Jesse Norell Well-Known Member

    Is the suexec module installed and enabled?
     

Share This Page