use https for on 8080 for ispconfig 3

Discussion in 'Installation/Configuration' started by dpicella, Apr 27, 2009.

  1. dpicella

    dpicella New Member

    Hi!

    I installed ispconfig 3 and I would like to use https://myserver:8080

    I generated a self signed crt and key and tried adding mod_ssl.c to the VirtualHost section (below), but that did not work... Any ideas?

    Thanks!

    # vi /etc/httpd/conf/sites-available/ispconfig.vhost
    Code:
    ######################################################
    # This virtual host contains the configuration
    # for the ISPConfig controlpanel
    ######################################################
    
     Listen 8080
    NameVirtualHost *:8080
    
    <VirtualHost _default_:8080>
      ServerAdmin webmaster@localhost
    
      <IfModule mod_fcgid.c>
        DocumentRoot /var/www/ispconfig/
        SuexecUserGroup ispconfig ispconfig
        <Directory /var/www/ispconfig/>
          Options Indexes FollowSymLinks MultiViews +ExecCGI
          AllowOverride AuthConfig Indexes Limit Options FileInfo
          AddHandler fcgid-script .php
          FCGIWrapper /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter .php
          Order allow,deny
          Allow from all
        </Directory>
      </IfModule>
    
      <IfModule mod_php5.c>
        DocumentRoot /usr/local/ispconfig/interface/web/
        AddType application/x-httpd-php .php
        <Directory /usr/local/ispconfig/interface/web>
          Options FollowSymLinks
          AllowOverride None
          Order allow,deny
          Allow from all
              php_value magic_quotes_gpc        0
        </Directory>
      </IfModule>
    
      <IfModule mod_ssl.c>
        SSLEngine on
        SSLCertificateFile /usr/local/ispconfig/interface/ssl/server.crt
        SSLCertificateKeyFile /usr/local/ispconfig/interface/ssl/server.key
      </IfModule>
    
      # ErrorLog /var/log/apache2/error.log
      # CustomLog /var/log/apache2/access.log combined
      ServerSignature Off
    
    </VirtualHost>
    
    <Directory /var/www/php-cgi-scripts>
        AllowOverride None
        Order Deny,Allow
        Deny from all
    </Directory>
    
    <Directory /var/www/php-fcgi-scripts>
        AllowOverride None
        Order Deny,Allow
        Deny from all
    </Directory>
    
    
     
  2. dpicella

    dpicella New Member

    SSL on 8080 VirtualHost Config

    Maybe *:8080 should be ipaddress:8080 ... just a thought

    By the way ... does anybody know what command I can use to restart ISPConfig without rebooting? Thanks!
     
  3. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    ISPConfig is no daemon, so it neither needs to be restarted nor it can be restarted. If you want to restart apache, then use the apache start script.
     
  4. dpicella

    dpicella New Member

    OK ... that is new. ISPConfig 2 had the ispconfig_server daemon.

    Thanks!
     
  5. dpicella

    dpicella New Member

    Mod ssl was not installed - problem solved

    I did some investigation and discovered that mod_ssl was not installed.

    # yum install mod_ssl
    # /etc/init.d/httpd restart

    Worked! Now I can use https://mysite:8080 with the conf file above.
     

Share This Page