Use default PHP version in /usr/share/afterlogic/

Discussion in 'Plugins/Modules/Addons' started by paka, Nov 11, 2020.

  1. paka

    paka Member

    Issue: Default PHP version is 7.3. However when AfterLogic's WebMail runs from:
    Code:
    /use/share/afterlogic/
    The default PHP version doesn't run. What does run is 5.6.
    This is also an issue when upgrading WebMail as doing so via apt returns this error (due to Composer):
    Code:
    Composer detected issues in your platform:
    Your Composer dependencies require a PHP version
    ">= 7.3". You are running 5.6.40-38+0~20201103.42+debian9~1.gbpb211e0.
    Created a file called 'version.php' with the single line:
    Code:
    <?php echo PHP_VERSION;
    ... and copied version.php to the 'web' directory and another to /usr/share/afterlogic
    Then viewed each from a web browser. When viewing version.php from the regular web directory it displays v7.3 is in use.
    However, when displayed from the /usr/share/afterlogic/ directory, this is returned:
    Code:
    5.6.40-38+0~20201103.42+debian9~1.gbpb211e0
    The URL to reach that directory looks like this:
    https://domain.com/afterlogic/version.php
    Verifying the default PHP version:
    Code:
    Selection    Path                  Priority   Status
    ------------------------------------------------------------
    0            /usr/bin/php.default   100       auto mode
    1            /usr/bin/php.default   100       manual mode
    2            /usr/bin/php5          50        manual mode
    3            /usr/bin/php5.6        56        manual mode
    4            /usr/bin/php7.0        70        manual mode
    * 5            /usr/bin/php7.3        73        manual mode
    6            /usr/bin/php7.4        74        manual mode
    What needs to be done in order to run either the default version or a specifically designated PHP version when running from /usr/share/afterlogic or running apt?
     
  2. ahrasis

    ahrasis Well-Known Member

  3. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    Does that mean the default (7.3) is incompatible, and it requires 5.6? Or that means you expect 7.3, but instead find 5.6?

    Another thing to check is that you don't have an old 5.6 mod_php installed; you can (should? actually must if you want http2) uninstall all mod_php versions and enconf the correct php-fpm version as the default php handler.
     
  4. paka

    paka Member

    What I was trying to say is that when updating AfterLogic using APT, the error indicates that (Composer2) is detecting 5.6, yet requires >= 7.0.

    Thanks for mentioning old 5.6 mods. I'm always a bit hesitant about removing older versions as it seems every time I do there is something that requires it's uses and it takes a bit of time until i hear of the problem. <sigh>

    I notice the server has a number of php5-* packages installed (below an example of just 3) in addition to what I believe is a full set of php5.6-* packages.
    i php5-apcu - APC User Cache for PHP 5
    i php5-cgi - server-side, HTML-embedded scripting language (CGI binary)
    i php5-cli - command-line interpreter for the php5 scripting language
    i php5-common - Common files for packages built from the php5 source
     
  5. paka

    paka Member

    Thanks. However it would seem the default for CLI is, indeed, 7.3 as well as for Apache.
    The only time the machine uses 5.6 is when using files in the following directory which is outside of the http-docs directory:
     
  6. ahrasis

    ahrasis Well-Known Member

    It is just a guess since your info said composer detected your php version as not equivalent or more than supposedly be i.e. php7.3.
     

Share This Page