USB filesystem type problem

Discussion in 'Technical' started by etumbaga, Oct 19, 2006.

  1. etumbaga

    etumbaga New Member

    I'm trying to install a 2Gb USB storage device to one of my guest domains. I'm using a Xen config with kernel "vmlinuz-2.6.16.xenu". Now I mount the USB device from the host, the devices is seen as:

    "/dev/sdb"

    I attach the said device to the guest host (say Domain ID 24), using the "xm block-attach" method:

    sudo xm block-attach 24 phy:/dev/sdb sdb rw

    This works fine, I can see that the device has been attached to the guest domain:

    "/dev/sdb"


    To access the device, I try to mount it as a folder, /mnt/usb:


    mount /dev/sdb /mnt/usb

    This comes up with the error:


    mount: Unknown filesystem type 'vfat'


    Tried using the "-t" option, to declare the filesystem (I know that the filesystem of my USB device is VFAT).


    mount -t vfat /dev/sdb /mnt/usb


    Got the same result. I tried mounting the same USB device to the host, using the same mount line


    mount /dev/sdb /mnt/usb


    Worked just fine. The device was succesfully mounted. My host OS is Ubuntu, if it matters.


    My question is, is the "vfat" filesystem is supported by the VM guest kernel "vmlinuz-2.6.16.xenu"? If not, is there a way to "install" or "define" the said filesystem in the guest VM? I need to be able to access my USB storage device in my guest domain/VM.

    Hoping someone could help me out. Thanks in advance.



    Edwin
     
  2. falko

    falko Super Moderator

    I think your domU kernel doesn't support vfat. You have to compile a new domU kernel that supports it (or format your USB stick with a filesystem that's supported by your domU kernel).
     
  3. narayanan

    narayanan New Member

    I have a similar problem. I have a USB drive formatted using fat32. I checked the kernel configuration. I have built VFAT fs support as a module. Should I have enabled built in support ?
     
  4. falko

    falko Super Moderator

    Did you load the module?
     

Share This Page