URL's show router admin page from inside internal network

Discussion in 'Installation/Configuration' started by jopa123, May 3, 2007.

  1. jopa123

    jopa123 New Member

    Hey guys,

    Things are working geat. Nice job. I'm still learning, tho.

    I cannot figure this one out.

    My setup:
    Belkin Pre-n Wireless router
    (wireless not good, I know, but it's just a test server)
    (router supports loopback)

    1 - PC w/Windows Vista (ip = 192.***.*.25)
    2 - PC's w/ Windows XP (dynamic internal ip's)
    1 - Linux w/ Ispconfig - FedoraCore4 Perfect Setup (ip = 192.***.*.26)

    My problem:
    I can see my websites, login to ispconfig, admin the server, etc., from outside my network. However, from the Vista PC, inside my internal network, the url's show my router's admin page.

    I cannot bypass the router since it is in another part of the house.

    I work in Dreamweaver and Photoshop on the PC, so i would like to check my work without having to go to the Linux box to see it.

    I know I have seen this problem discussed before, but a search of the forums came up empty.

    Any possibilities?

    Thanks in advance for any help.

  2. zcworld

    zcworld New Member

    if your on windows desktop pcs
    do this
    goto run
    and type in "" notepad %windir%\system32\drivers\etc\hosts ""
    and put in there
    the lan IP of the host PC and the domain name vdb.lan

    and do the same for the other domains you got
    save it
    if firefox or IE is open close them and than try your URL site again
    see if thats helps

    < if you on linux than just use your fav text editor and edit the /etc/hosts
    file and do the same for winodws
    IP <tab> domain URL

    so on

    happy use
  3. jopa123

    jopa123 New Member

    Didn't work


    On the linux server w/ispconfig I edited the /etc/hosts file to include:

    192.168.*.* mydomain1.com
    192.168.*.* mydomain2.com

    No luck.

    I tried to do the same on my Vista PC, but got an access denied message when I tried to save it. I will try my best to disable Vista's security on this file if that is the answer. But I'm new to that operating system as well.

    Any other places to look?

    thanks again
  4. falko

    falko Super Moderator ISPConfig Developer

    Yes, you must edit the hosts file on the client PCs. Not sure how to do this on Vista though.
  5. jopa123

    jopa123 New Member

    No luck

    OK, Got the host file on the client pc edited but still the same issue. Any other ideas?
  6. jopa123

    jopa123 New Member


    Just found this in an article:

    "Belkin routers have a WAN loopback. That means if you are hosting a web page internally (using virtual servers) you won't be able to see it....unless you put a PC on the WAN side - kind of a pain in the butt."

    Does this mean I'm out of luck? Is there another way to see the site? Maybe a url like http://**.***.**.**/domain.com or something?
  7. zcworld

    zcworld New Member

    all routers
    if you try to look at ur WAN IP
    you will get your router
    its just the default thing

    to the key part of the qus there

    try and do what i said before
    set the IP / DNS name to site
    in your windows hosts file
    and it would work fine
    i done that with all of my sites before i had my firewall linux box working .....
  8. jopa123

    jopa123 New Member


    Thanks again.

    But, as I said I got the file edited (after wrestling with Windoze's security). Doesn't seem to help.

  9. falko

    falko Super Moderator ISPConfig Developer

    Maybe there's some sort of DNS cache on your Windows system. Have you tried to reboot the Windows system to clear the cache?
  10. jopa123

    jopa123 New Member

    Still no

    I cleared all cache and, thanks to the weather here in Texas lately, all the machines including the router have been rebooted several times.

    Also, I finally got around to installing Firefox on the Vista system. First website I tried to go to was my own. Same issue.

    I'll go back and check the host file on the Linux server but I think it's a router issue. Maybe it doesn't support loopback.

    Once again, thanks for all the help.

  11. falko

    falko Super Moderator ISPConfig Developer

    That's possible, but if you use the local IP address of your server in the hosts file instead of your router's public IP address, it should work (because then the router has nothing to do with it).
  12. Zandooy

    Zandooy New Member

    This is how I solved the problem

    I had the exact same problem. I contacted my ISP because I have a business account and business accounts get priority tech support and even they had no idea what to do about it. I have a westell 7500 modem. This particular modem has a certain feature that lets me configure DNS in certain ways. In the advanced settings of my modem I can access a feature called "DNS Server". Under "DNS Server" I can create a table of domain names and the IP addresses I want them to resolve to. One of the domains in my ISPConfig system is "zandooy.com" so I added zandooy.com to the DNS Server table in my modem with the Local IP address of my Server on my network (ie. zandooy.com /// Then I can just put http://zandooy.com/ in my browser of any other PC on my local network and it gets redirected to my server machine within the same network. BINGO! I can now browse the websites on my server inside my LAN using the domain names. You might try looking for this feature in your router or modem. It may not be labeled the same way if it has it at all.

    Good Luck!
  13. HaydenHarnet

    HaydenHarnet New Member

    Got the host file on my client computer edited but it still the same issue. Any other ideas?

    linksys e2000
    Last edited: Aug 5, 2010

Share This Page